Bug Hunting Session
Bug 37583 - EDITING: 'Format paintbrush' causes scroll from last to first page
Summary: EDITING: 'Format paintbrush' causes scroll from last to first page
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-25 06:50 UTC by velteyn
Modified: 2011-12-23 13:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Copy Format Tool (19.79 KB, image/png)
2011-05-26 01:51 UTC, velteyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description velteyn 2011-05-25 06:50:05 UTC
When you highlight a formatted text and than click Format Paintbrush sometimes the Tool jumps to the top page !!
Comment 1 Rainer Bielefeld Retired 2011-05-25 08:04:22 UTC
No idea what the problem might be, my "LibreOffice 3.4.0RC1  – WIN7  Home Premium  (64bit) English UI [OOO340m1 (Build:11)]" does not have a "Paintbrush" tool.

@velteyn:
May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport> carefully?
Then please:
- Write a meaningful Summary
- Attach a sample document 
- Attach screenshots with comments (you can add information using LibO DRAW
  and then attach your screenshot with comments as PDF) if necessary
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem
- add information 
  -- what exactly is unexpected
  -- and why do you believe it's unexpected
  -- concerning your PC (especially: video card)
  -- concerning your OS
  -- concerning your LibO localization (UI language)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration ...)
  -- how you launch LibO
  -- everything else crossing your mind after you read a.m. URL
Can you please file Bug reports with status UNCONFIRMED if your are not absolutely sure that you contributed all required background information and that the problem will be reproducible with information you can provide?

Thank you!
Comment 2 velteyn 2011-05-26 01:51:39 UTC
Created attachment 47179 [details]
Copy Format Tool

This is the Brush tool we in Italy call: "Copia Formato" , the exact English name is a mystery for me !!
Comment 3 velteyn 2011-05-26 02:00:09 UTC
I try to express myself better. My English is not the maximum. 

I attached an image of what I call  Format Paintbrush !!

So

1) Highlight some text 
2) press Format Paintbrush
3) SOMETIMES the Writer jumps into the first page of the document

So , if you want to copy the format into a text on page 44 the writer jumps to page 1 !!!

Sometimes it happens , sometimes not

I'm going to investigate the exact moments when it happens

Expressing better than this is not possible for me right now so I hope this is sufficient. :)

Bye
Edoz
Comment 4 sasha.libreoffice 2011-06-01 08:28:55 UTC
Reproduced on Mandriva 64 bit and Windows XP 32 bit on LibO 3.4 rc1
But I not sure that is described problem or another problem.
Steps to reproduce:
1. Open any multipage Writer document
2. Place cursor or select something on first page
3. Scroll to last page
4. Press "Format Paintbrush" tool (on Standard toolbar)
Actually: document scrolls to first page
Expected: document remains on current page
Comment 5 Rainer Bielefeld Retired 2011-06-05 10:38:12 UTC
But I observe an unexpected small jump for what I created a new issue:
"Bug 37955 - Page scrolls after click on 'Format paintbrush' when mouse pointer reaches document text" 

@velteyn
Still missing sample document, information concerning your PC, your OS, LibO localization, ...

May be your problem is related to my one? It would be great if you would try to reproduce it.

@sasha:
I can confirm your observations, but I believe it's not a bug. In HELP you can read that you should first press 'Format Paintbrush', then scroll to test that should get new format. So it even might be intended to show the format source after you clicked the icon. I sometimes think that's annoying, but for me that is not a big problem. If you have good reasons to propose a change of the behavior, you should write an Enhancement request. It might be useful to invite the Design Team or adding me to CC.

Can you please try to reproduce the problem in the new bug report?
Comment 6 sasha.libreoffice 2011-06-14 23:09:33 UTC
@velteyn:
I understand this problem: when Paintbrush selected, text scrolls autumatically when we move mouse over top or bottom of screen of text (few millimeters near horizontal rule on top or status window on bottom)
Text scrolls too fast and it looks like it jumps.
To solve this problem undock standard toolbar (where Format Paintbrush) and dock it on left or right margin of screen or leave it floating