Bug Hunting Session
Bug 37623 - Auto Filter disables incremental autofill function
Summary: Auto Filter disables incremental autofill function
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.0 RC1
Hardware: All All
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:6.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-26 04:48 UTC by Rainer Bielefeld Retired
Modified: 2018-05-06 08:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Pls see original report (9.18 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-05-26 04:48 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-05-26 04:48:40 UTC
Created attachment 47188 [details]
Pls see original report

I found that with "LibreOffice 3.4.0RC1  – WIN7  Home Premium  (64bit) English UI [OOO340m1 (Build:11)]"

Steps to reproduce: 
1. open attached "sample.ods"
2. Click A21
3. Click Fill handle and drag / drop it until cells ...A25 will be filled. 
   So you should have done the Fill > Series function and new contents of cells 
   should be numbers 21 ... 24 in A21:A25
4. click undo button before nest test
   All new contents should disappear
5. Use Filter: Click Auto Filter arrow in column E with ehading "e"
6. Filter "empty"
   Nothing should happen, all cells are empty in this column
8. redo from step 2 ... step 4
   Expected: same result, numbers 21 ... 24 in A22:A25
   Actual: All new cell contents is "20"

I also tested with OOo 3.1.1, there fill handle works as expected also with active filter.

I only see that problem having used Auto Filter. Doing the same filtering with Standard Filter does not show the broken fill series effect.

I believe this is a regression, I believe I would have remarked if that would had happened in stable LibO versions.

Related Help:
<http://help.libreoffice.org/Calc/Automatically_Calculating_Series>
Comment 1 André Schnabel 2011-06-18 14:04:55 UTC
confirmed using LibO 3.4.1RC1 on linux 32bit
Comment 2 Markus Mohrhard 2011-06-23 19:33:58 UTC
Can you retest with 3.4.1 RC2 or RC3? I think Katarina changed something post 3.4.0 RC1 but otherwise I might have a look at it.
Comment 3 Kohei Yoshida 2011-12-09 14:09:24 UTC
For me the auto fill series is not working on this data set even without playing with the filter.
Comment 4 Kohei Yoshida 2011-12-09 19:15:37 UTC
This is a side effect of fixing this bug:

https://issues.apache.org/ooo/show_bug.cgi?id=89232

This was fixed by someone from IBM in OOo, whose patch we've integrated.  With this change, when performing autofill on a database area, auto-increment no longer works even when the selected range contains no filtered rows.
Comment 5 Kohei Yoshida 2011-12-09 19:30:52 UTC
Interestingly, Excel has the same limitation.

When you try to autofill within a range that has autofilter on, you can never do incremental autofill.  Even the manual fill series doesn't work.  So, this behavior may be intentionally introduced by that change.

I can sort of see why since incrementing over a filtered area is quite complex.
Comment 6 Kohei Yoshida 2011-12-09 19:36:02 UTC
Better title.  The word 'corrupt' is too strong a word for this sort of limitation.  And since the change may have been intentional, I don't consider this a regression.

However, it would be nice to be able to do incremental autofill over a database range.  So I'll leave this bug report open for that.
Comment 7 Markus Mohrhard 2012-04-14 04:46:49 UTC
Is solved in master.

We now always skip hidden rows/columns regardless if they are from an autofilter or from manual interaction.
Comment 8 Commit Notification 2018-05-06 08:28:17 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ff5fef04c9a0c0c722d2af815333bcec172c15d7

uitest for bug tdf#37623

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.