Download it now!
Bug 37628 - "Change password" button is always disabled
Summary: "Change password" button is always disabled
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.4.0 RC1
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: target:3.5 target:3.4.3
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-26 06:44 UTC by Takashi Nakamoto
Modified: 2011-07-27 07:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Takashi Nakamoto 2011-05-26 06:44:29 UTC
"Change password" button in Property dialog (File -> Properties -> General) is always disabled even when I open an encrypted document.

I failed to clarify the condition where this bug appears. In my environment (Win 7, LO 3.4 rc1, x86-64, Writer/Calc), this problem always occurs. Another user reports that this problem can be seen also on WinXP SP3.
http://listarchives.libreoffice.org/ja/discuss/msg00567.html
Comment 1 Kohei Yoshida 2011-05-26 08:43:12 UTC
Confirmed.  I'll take a look at this.
Comment 2 Kohei Yoshida 2011-05-26 11:39:30 UTC
Unfortunately this is going to be an easy fix.  It appears that encryption and password handling has changed dramatically between 3.3 and 3.4 in the OOo code base to avoid storing the raw password data in memory.  To make matters worse each file format encryption type uses a different hash algorithm, so when you change the password, we need to generate hashes for all hash types that we support.  In 3.3, all we had to do was update the raw password stored in memory.  This is a big difference.

This is going to be a long battle, and no guarantee this will make it into 3.4.1.
Comment 3 Kohei Yoshida 2011-05-26 11:43:14 UTC
Code pointer for future investigation (when I resume work on this).

SfxDocumentPage::ImplCheckPasswordState() determines the state of the button, and the password hashes are stored in the property bag in the item set associated with SID_ENCRYPTIONDATA.  The old password was stored with SID_PASSWORD.
Comment 4 Takashi Nakamoto 2011-05-29 01:11:43 UTC
Is this feature always disabled in LO 3.4.0 in any platform?
If so, I think we should strike out this feature from the 3.4 new feature list.
 http://wiki.documentfoundation.org/ReleaseNotes/3.4.
Comment 5 Kohei Yoshida 2011-05-31 07:14:36 UTC
Can you talk to Cor Nouws about this?  That page is "frozen" and its editing right is now in the hands of the marketing folks AFAIK.

Looks like OOo has added the same functionality between 3.3 and 3.4 anyway.  I might just remove my addition (since it's not working anymore).

I tried to add Cor in CC, but the email address I have doesn't match the one in bugzilla, apparently.
Comment 6 Kohei Yoshida 2011-05-31 07:15:19 UTC
Ah, I found his email address for bugzilla.  Adding Cor in CC.
Comment 7 Kohei Yoshida 2011-07-22 07:32:32 UTC
Re-assigning to Markus.
Comment 8 Markus Mohrhard 2011-07-23 08:56:34 UTC
Ok, I think I got it and with some reorganization it should be possible to include this in 3.4.3 but I need to investigate it a bit further.

Button is already enabled correctly only setting the new password is a bit more tricky.
Comment 9 Markus Mohrhard 2011-07-24 11:32:39 UTC
possible fix sent to the ML for review

dialog has changed its appearance, I use now the password dialog that will be displayed during filesave
Comment 10 Markus Mohrhard 2011-07-27 07:53:32 UTC
has been accepted for 3.4.3