Bug 37638 - Index randomly broken up with extra white space
Summary: Index randomly broken up with extra white space
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL TableofContents-Indexes Repagination
  Show dependency treegraph
 
Reported: 2011-05-26 11:36 UTC by Nadav Har'El
Modified: 2018-09-17 16:54 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
A (Hebrew) document demonstrating the problem. See the third index page (page 63) for (141.48 KB, application/vnd.oasis.opendocument.text)
2011-05-26 11:36 UTC, Nadav Har'El
Details
What the bug looks like - extra white space in the middle of the index. (54.12 KB, image/png)
2011-05-26 11:38 UTC, Nadav Har'El
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nadav Har'El 2011-05-26 11:36:21 UTC
Created attachment 47194 [details]
A (Hebrew) document demonstrating the problem. See the third index page (page 63) for 

This is a longstanding bug, which I've seen for at least a year, also in OpenOffice, and still remains in LibreOffice (as installed on my shiny new Fedora 15).

In the attached document, which is in Hebrew, there is a 5-page long index at the end.

Most of the index is correctly formatted the way I wanted, with 5 columns ordered from right to left (as should be in Hebrew), correct page numbers, and so on. But, there is one, rather nasty, bug:

In the middle of the index - on the third index page (page 63) - there's suddenly a big gaping hole of white space. It doesn't appear that any index entry is missing - it's just extra, completely uncalled-for white space.
See attached image from the exported PDF file (the exact same problem appears also on-screen).

Even more strangely, the location of that space in the middle of the index isn't constant: When I do Tool->Update->Update All and the index is regenerated, the location of that whitespace usually changes. Usually it picks one or two locations for it, but once in a blue moon, I also get a good unbroken index.
Comment 1 Nadav Har'El 2011-05-26 11:38:01 UTC
Created attachment 47195 [details]
What the bug looks like - extra white space in the middle of the index.
Comment 2 Björn Michaelsen 2011-12-23 12:01:00 UTC Comment hidden (obsolete)
Comment 3 Florian Reisinger 2012-08-14 13:57:09 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 13:58:32 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:03:04 UTC Comment hidden (obsolete)
Comment 6 Florian Reisinger 2012-08-14 14:05:19 UTC Comment hidden (obsolete)
Comment 7 sasha.libreoffice 2012-09-06 10:36:05 UTC
not reproduced in 3.6.1. WFM
Comment 8 Nadav Har'El 2012-09-06 12:00:54 UTC
I tested this on LibreOffice 3.5.6 and at first was thrilled to see the bug indeed went away.

BUT, on second check, I discovered that it didn't. It just takes a slightly different procedure to see it:

When you first open the attached document, you don't see odd white space in the index at the end.
But, if now you do Tools->Update->Update All, to recalculate the index, *now* you'll see that extra white space on page 63.

That bug still exists in LibreOffice 3.5.6 (the latest I have access to).

So I'm reopening the bug.
Comment 9 sasha.libreoffice 2012-09-07 05:58:07 UTC
Thanks for additional information.
Reproduced in 3.3.4 and 3.6.1 on Fedora 64 bit (Windows not tested)
used Tools->Update->Update All
Comment 10 Lior Kaplan 2012-11-10 14:59:43 UTC
Also reproducible in 3.7/master, but seems a bit less random than I thought.

@Nadav - did you check the problem in other languages or it just happen to be Hebrew document as this is what you've worked with?
Comment 11 Nadav Har'El 2012-11-10 17:13:21 UTC
(In reply to comment #10)
> @Nadav - did you check the problem in other languages or it just happen to
> be Hebrew document as this is what you've worked with?

I've only seen this problem in this specific document, which is in Hebrew. I don't know whether the bug is specific to RTL or Hebrew (less likely), or whether it is specific to indexes, to multi-column text, or what.

I was hoping that someone with actual access and understanding of the source code could easily (?) debug where that extra white space is coming from, since it is consistently being added.

As to being random, it does appear sort-of-random, but if you always use the same "seed" (open the same file, do the same sequence of events) then indeed the white space always appears in the same place. As I continue to edit this document, I notice that the white space seems (unless I'm just remembering it wrong) drift from place to place.
Comment 12 Nadav Har'El 2013-10-01 14:43:22 UTC
This bug still exists in LibreOffice 4.1.2.2. After I do an "update" of the index, it gets a big hole in the middle. Luckily, a "save" after the update doesn't save the hole: When quitting LibreOffice and starting it again, I again see a nice index, without a hole.
Comment 13 QA Administrators 2015-04-01 14:39:54 UTC Comment hidden (obsolete)
Comment 14 Buovjaga 2015-04-19 13:02:56 UTC
(In reply to Nadav Har'El from comment #12)
> This bug still exists in LibreOffice 4.1.2.2. After I do an "update" of the
> index, it gets a big hole in the middle. Luckily, a "save" after the update
> doesn't save the hole: When quitting LibreOffice and starting it again, I
> again see a nice index, without a hole.

Confirmed hole on page 63 after update.

Lowered severity per comment 12.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha0+ (x64)
Build ID: 211c12b9c64facd1c12f637a5229bd6a6feb032a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-18_01:51:17
Locale: fi_FI

Ubuntu 14.10 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 15 Buovjaga 2015-04-19 13:15:39 UTC
Re: my previous comment: oops, I made a mistake: I actually tested using 4.4.2 on Windows. LibO 5.0 64-bit on Windows crashes with SEH Exception: Access violation, when I open the document.

Ubuntu master does not have the hole, when updating.

Version: 4.5.0.0.alpha0+
Build ID: afb82d3729bda2754d0add08cc6c4dce1dc76d59
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-04-14_00:05:04
Locale: en_US
Comment 16 QA Administrators 2016-09-20 10:00:11 UTC Comment hidden (obsolete)
Comment 17 Nadav Har'El 2017-04-20 07:49:02 UTC
Unfortunately, I can still reproduce the bug in LibreOffice 5.2.6.2 (from the Fedora 25 package).

To reproduce:
1. Open the document in the attachment, the index at the end of the document looks fine.
2. Use "Tools -> Update -> Update All"
3. In the middle of the index, in page 69, I see a "hole" - unexpected white (gray, actually) space, roughly one column-length long, between two index entries (looks very much like the attached image, but the space comes between different words this time). By the way, no index entry is missing - the space is extra, it doesn't hide any content. You don't need to understand Hebrew to see the empty space :-)
Comment 18 Yousuf Philips (jay) (retired) 2017-10-20 10:29:30 UTC
I believe this to be a repagination issue, as the issue happens sometimes and doesnt other times. Also encountered that sometimes when the white space appears and then i scroll to another page and scroll back and the white space is gone. Also noticed that if i update the index at the place of the white space, the white space will disappear. I believe the 5 columns has a factor in it, as some entries wrap over two lines, and if its set to 4 columns, the white space didnt appear.

Version: 6.0.0.0.alpha1+
Build ID: 143c482b3189cb084fbdf5e6f78f15b43f099e24
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 19 Omer Zak 2017-11-01 20:28:14 UTC
I saw the problem after performing Tools->Update->Update All, as per Comment 8 (https://bugs.documentfoundation.org/show_bug.cgi?id=37638#c8) in:

Version: 5.4.2.2.0+
Build ID: 1:5.4.2-3~bpo9+1
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.utf8); Calc: group

OS: Debian 64bit Stretch (Debian 9.2, with some backported packages)
Comment 20 eladhen2 2018-03-03 00:18:26 UTC
The bug is still present in Libreoffice 6.0.1.1.
Comment 21 Omer Zak 2018-09-17 16:37:00 UTC
The problem was not seen.
The document's pagination was changed, and now the location which used to have a gap is now in page 68 rather than page 63.


גרסה: 6.1.1.1
מזהה הבנייה: 1:6.1.1~rc1-2~bpo9+1
תהליכי משנה במעבד: 8; מערכת הפעלה: Linux 4.16; עיבוד מנשק: בררת מחדל; VCL: gtk2; 
מיקום: en-US (en_US.UTF-8); Calc: group threaded

running under Debian Stretch:
$ uname -a
Linux c5 4.16.0-0.bpo.2-amd64 #1 SMP Debian 4.16.16-2~bpo9+1 (2018-06-26) x86_64 GNU/Linux
Comment 22 Lior Kaplan 2018-09-17 16:54:03 UTC
Doesn't happen on initial open of the file. Still reproducible after doing Format -> Update -> All.

Version: 6.1.1.1
Build ID: 1:6.1.1~rc1-2

On Debian GNU/Linux AMD64.