Bug 37642 - Writer page numbering offset not working
Summary: Writer page numbering offset not working
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) Linux (All)
: lowest minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-26 12:38 UTC by Christopher M. Penalver
Modified: 2019-02-04 07:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2011-05-26 12:38:33 UTC
Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/118935

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in Writer is when one clicks Insert -> Field -> Page Numbers -> double click page number -> change offset from 0 to 6 -> OK button

-OR-

Insert -> Field -> Other -> Page -> Page Numbers -> Offset 6 -> Insert button

it shows the first Page Number object with 6 inside.

4) What happens instead is it shows a blank object.

WORKAROUND: click Format -> Paragraph -> Text Flow tab -> Insert checkbox checked -> With Page Style checkbox checked -> Page number combobox 6 -> OK button
Comment 1 Regina Henschel 2011-05-26 14:25:24 UTC
The meaning of the offset is: Do not show the actual page number but show the number of the page, that is 6 pages ahead. And if there is no such page, then nothing it shown.
The offset does not change the actual page number and was never intended to do so.
Comment 2 Regina Henschel 2011-05-26 14:25:49 UTC
No bug.
Comment 3 Mantas Kriaučiūnas 2014-04-28 14:02:31 UTC
It seems there are no intuitive way to insert page numbers into text document with different starting number :(
LibreOffice developers, please change behavoir of Insert -> Field -> Other -> Page -> Page Numbers -> Offset to user-friendly.
Comment 4 retired 2014-04-29 09:56:28 UTC
Just tested https://bugs.freedesktop.org/show_bug.cgi?id=44689 and set that to "fixed" since it seems to work.

To offset a page number in LO you need at least as many pages in the document as which you want to offset.

worksforme:

* create writer document with 3 pages
* insert > Field (loose translation here!) > Page number
* double click page number
* enter correction (loose translation!) value of "1"

Page number should display 2 while inserted on first page

If you think this is bad behavior, please create a new bug with exact suggestions about what you would like to see improved and in what why that could be done.

Offset in general does work, so closing this very old bug.
Comment 5 peterpen 2019-02-04 07:36:30 UTC Comment hidden (spam)