Download it now!
Bug 37697 - Use object alignment buttons in Frame and OLE-Object toolbars rather than text alignment buttons
Summary: Use object alignment buttons in Frame and OLE-Object toolbars rather than tex...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: All All
: medium normal
Assignee: Yousuf Philips (jay) (retired)
URL:
Whiteboard: target:6.1.0 target:6.0.0.1 target:6....
Keywords:
Depends on:
Blocks: Toolbars Frame OLE-Objects
  Show dependency treegraph
 
Reported: 2011-05-28 08:51 UTC by ape
Modified: 2017-12-21 16:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document, see Comment 2 (101.45 KB, application/vnd.oasis.opendocument.text)
2011-05-29 00:35 UTC, Rainer Bielefeld Retired
Details
Toolbars merged into one picture (EN and RU Languages) (151.90 KB, image/png)
2011-05-29 21:21 UTC, ape
Details
This summary figure shows should look like "1.png" if my suggestions (Description, Comment_1, Comment_6) will be taken. (154.87 KB, image/png)
2011-05-29 23:54 UTC, ape
Details
With_Calc_Fjrmating (226.52 KB, image/png)
2011-05-31 08:31 UTC, ape
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ape 2011-05-28 08:51:03 UTC
Buttons of object alignment of control panels 'Frame' and 'OLE-object' are used with icons of text alignment of control panels 'Formattings' and 'Table'. It is a mistake. Icons, same as well as icons of control panel 'Align' should be used.
Comment 1 ape 2011-05-28 21:28:28 UTC
The names of the buttons object alignment, causing the same action, differ in toolbars 'Frame' \ 'OLE-object' and the toolbar 'Align'. Names, same as well as names of the toolbar 'Align' should be used.
Comment 2 Rainer Bielefeld Retired 2011-05-29 00:34:30 UTC
[Reproducible] with "LibreOffice 3.4.0RC2  – WIN7  Home Premium  (64bit) English UI [OOO340m1 (Build:12)]" and TANGO theme. The current icons are misleading. In attached sample WRITER document you can use both possibilities for vertical alignment, the floating Align toolbar and the docked Frame toolbar.

The moving of the frame using the buttons in Align toolbar is predictable, you see a reference line and the position of an object relative to the reference line. 

For me the moving of the frame using the buttons in Frame toolbar is unexpected. I press the right button showing an object more nearby bottom of the page, and the frame moves up, that's without logic.

Currently I see this as a WRITER UI problem

@ape:
Can you please try to find out details concerning your OS, PC, LibO version for your reports (although if you expect that the problem is independent)   ;-)

Did you also see this problems for CALC, DRAW, Presentation?

@Michael:
I saw you active in ant least one similar bug report (Bug 36662)
Please feel free to reassign if it's not your area!
Comment 3 Rainer Bielefeld Retired 2011-05-29 00:35:39 UTC
Created attachment 47263 [details]
Sample Document, see Comment 2
Comment 4 ape 2011-05-29 08:06:48 UTC
OS - Windows_XP_64bit_ENU+MUI_RU,LibO-3.4.0rc2. But this error appears in the Linux OS (Ubuntu-10.04_LiveCD). This same error found in the OpenOffice.org-2.4.2.
Comment 5 ape 2011-05-29 09:00:39 UTC
@Rainer Bielefeld
Description concerns to Writer.
Draw, Impress - access to objective alignment is carried out through the button 'Alignment' (Drawing_Object_Properties toolbar); toolbars 'OLE-object' and 'Frame' available in the View menu.
Calc - the object inserted into a cell of a sheet, in a cell is not positioned, the toolbar 'Align' not activated.
Comment 6 ape 2011-05-29 20:55:20 UTC
I specify a comment_1.
As it seems to me, it is necessary to change the name of control buttons:
1. Toolbar 'Table':
- 'Center_(vertical)' to replace on 'Middle'.
2. Toolbars 'Frame' and 'OLE-object':
- 'Align_left' to replace on 'Left';
- 'Center_Horizontal' to replace on 'Symmetrically';
- 'Align_Right' to replace on 'Right';
- 'Top' to replace on 'Above';
- 'Bottom' to replace on 'Below'.
3. Toolbar 'Align':
- 'Centered' to replace on 'Symmetrically';
- 'Top' to replace on 'Above';
- 'Bottom' to replace on 'Below'.
Comment 7 ape 2011-05-29 21:21:29 UTC
Created attachment 47293 [details]
Toolbars merged into one picture (EN and RU Languages)
Comment 8 ape 2011-05-29 23:54:27 UTC
Created attachment 47294 [details]
This summary figure shows should look like "1.png" if my suggestions (Description, Comment_1, Comment_6) will be taken.
Comment 9 ape 2011-05-31 08:31:45 UTC
Created attachment 47397 [details]
With_Calc_Fjrmating

Oh, I forgot about Calc (Toolbar 'Formating'): with icons - OK, but their names, in my opinion, is necessary for changing.
Comment 10 ape 2011-06-06 06:13:43 UTC
(In reply to comment #2)
> [Reproducible] with "LibreOffice 3.4.0RC2  – WIN7  Home Premium  (64bit)
> English UI [OOO340m1 (Build:12)]" and TANGO theme. The current icons are
> misleading. 
> 
> Currently I see this as a WRITER UI problem
@Rainer Bielefeld:
Such impression at you could be added because you use the TANGO theme.
It seems to me, I have found the reason which causes this error. The toolbar "Formating\Calc" uses the same icons, as well as toolbars "Frame" and "OLE-object": l{s}c_alignbottom.png; l{s}c_aligntop.png; l{s}c_alignverticalcenter.png; l{s}c_alignleft.png; l{s}c_alignright.png; l{s}c_alignhorizontalcenter.png.
The error will be eliminated in any of three variants.
1. The program code of toolbars "Frame" and "OLE-object" will use toolbar icons "Align":
- "l{s}c_aligndown.png" instead of "l{s}c_alignbottom.png";
- "l{s}c_alignup.png" instead of "l{s}c_aligntop.png";
- "l{s}c_alignmiddle.png" instead of "l{s}c_alignverticalcenter.png";
- "l{s}c_objectalignleft.png" instead of "l{s}c_alignleft.png";
- "l{s}c_objectalignright.png" instead of "l{s}c_alignright.png";
- "l{s}c_aligncenter.png" instead of "l{s}c_alignhorizontalcenter.png".
2. The program code of a toolbar "Formating\Calc" will use icons of toolbars "Formattings\Writer" and "Table\Writer":
- "l{s}c_cellvertbottom.png" instead of "l{s}c_alignbottom.png";
- "l{s}c_cellverttop.png" instead of "l{s}c_aligntop.png";
- "l{s}c_cellvertcenter.png" instead of "l{s}c_alignverticalcenter.png";
- "l{s}c_leftpara.png" instead of "l{s}c_alignleft.png";
- "l{s}c_rightpara.png" instead of "l{s}c_alignright.png";
- "l{s}c_centerpara.png" instead of "l{s}c_alignhorizontalcenter.png";
- "l{s}c_justifypara.png" instead of "l{s}c_alignblock.png".
   Images of toolbars "Frame" and "OLE-object" icons will correspond to images of toolbar "Align" icons:
- "l{s}c_aligndown.png" save as "l{s}c_alignbottom.png";
- "l{s}c_alignup.png" save as "l{s}c_aligntop.png";
- "l{s}c_alignmiddle.png" save as "l{s}c_alignverticalcenter.png";
- "l{s}c_objectalignleft.png" save as "l{s}c_alignleft.png";
- "l{s}c_objectalignright.png" save as "l{s}c_alignright.png";
- "l{s}c_aligncenter.png" save as "l{s}c_alignhorizontalcenter.png".
   The "l{s}c_alignblock.png" icon can be deleted from "images{_all}.zip\res\commandimagelist\.." folders.
3. The program code of toolbars "Frame" and "OLE-object" will use toolbar icons "Align":
- "l{s}c_aligndown.png" instead of "l{s}c_alignbottom.png";
- "l{s}c_alignup.png" instead of "l{s}c_aligntop.png";
- "l{s}c_alignmiddle.png" instead of "l{s}c_alignverticalcenter.png";
- "l{s}c_objectalignleft.png" instead of "l{s}c_alignleft.png";
- "l{s}c_objectalignright.png" instead of "l{s}c_alignright.png";
- "l{s}c_aligncenter.png" instead of "l{s}c_alignhorizontalcenter.png".
   The program code of a toolbar "Formating\Calc" will use icons of toolbars "Formattings\Writer" and "Table\Writer":
- "l{s}c_cellvertbottom.png" instead of "l{s}c_alignbottom.png";
- "l{s}c_cellverttop.png" instead of "l{s}c_aligntop.png";
- "l{s}c_cellvertcenter.png" instead of "l{s}c_alignverticalcenter.png";
- "l{s}c_leftpara.png" instead of "l{s}c_alignleft.png";
- "l{s}c_rightpara.png" instead of "l{s}c_alignright.png";
- "l{s}c_centerpara.png" instead of "l{s}c_alignhorizontalcenter.png";
- "l{s}c_justifypara.png" instead of "l{s}c_alignblock.png".
   "l{s}c_alignblock.png", "l{s}c_alignhorizontalcenter.png", "l{s}c_alignleft.png", "l{s}c_alignright.png", "l{s}c_alignbottom.png" "l{s}c_aligntop.png" and "l{s}c_alignverticalcenter.png" icons can be deleted from "images{_all}.zip\res\commandimagelist\.." folders.
Comment 11 Rainer Bielefeld Retired 2011-06-10 02:58:00 UTC
RC2 is bit by bit identical with release version, so separate items in the version picker are useless. Changes have been discussed with Michael Meeks.
Comment 12 A (Andy) 2013-05-05 11:23:38 UTC
for me a buggy behavior is reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

Steps Done:
1. Open with WRITER the attached sample document "sample.odt" from Rainer
2. Click the text frame in the document and assure that the FRAME and ALIGN toolsbar are shown/activated (go to the menu VIEW -> TOOLBARS)
3. Now use the TOP and BOTTOM toolbar icons from the ALIGN and FRAME toolbar

Result: TOP moves the text frame down and BOTTOM moves the text frame up in both toolbars -> this is inconsistent for me


changed the status
Comment 13 QA Administrators 2015-03-04 02:21:51 UTC Comment hidden (obsolete)
Comment 14 Buovjaga 2015-03-24 12:24:01 UTC
(In reply to A (Andy) from comment #12)
> for me a buggy behavior is reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
> 
> Steps Done:
> 1. Open with WRITER the attached sample document "sample.odt" from Rainer
> 2. Click the text frame in the document and assure that the FRAME and ALIGN
> toolsbar are shown/activated (go to the menu VIEW -> TOOLBARS)
> 3. Now use the TOP and BOTTOM toolbar icons from the ALIGN and FRAME toolbar
> 
> Result: TOP moves the text frame down and BOTTOM moves the text frame up in
> both toolbars -> this is inconsistent for me

Reproduced.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 15 tommy27 2016-04-16 07:28:38 UTC Comment hidden (obsolete)
Comment 16 QA Administrators 2017-05-22 13:26:49 UTC Comment hidden (obsolete)
Comment 17 Yousuf Philips (jay) (retired) 2017-12-05 08:55:07 UTC
Patch - https://gerrit.libreoffice.org/45850
Comment 18 Commit Notification 2017-12-06 14:39:19 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=24f50a40fc704b92a0aa6017f1877b4399926640

tdf#37697 Use object alignment buttons rather than text alignment

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Thomas Lendo 2017-12-06 17:03:11 UTC
Thank you, Jay. First this bug was laying around for over 6 years, now fixed within days. :)
Comment 20 Commit Notification 2017-12-15 00:13:50 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3cd7f15df1dbd4603f01fceed674486e4adc9c09&h=libreoffice-6-0

tdf#37697 Use object alignment buttons rather than text alignment

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2017-12-21 15:22:57 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e07937bb4eccda742b03bfa9e7f0eb9d4e899e4e

tdf#37697 Fix incorrect toolbar separator

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2017-12-21 16:13:00 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e673ca8aae33af5f6fbed31b17613173b3ef2c8a&h=libreoffice-6-0

tdf#37697 Fix incorrect toolbar separator

It will be available in 6.0.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.