Bug 37716 - FILEOPEN RTF: frame contents (graphics & text) missing when imported
Summary: FILEOPEN RTF: frame contents (graphics & text) missing when imported
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:4.1.0 target:4.0.3
Keywords: filter:rtf, regression
Depends on:
Blocks:
 
Reported: 2011-05-29 07:32 UTC by Christopher M. Penalver
Modified: 2015-12-17 11:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
narrateur.rtf (12.26 KB, application/rtf)
2011-05-29 07:32 UTC, Christopher M. Penalver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2011-05-29 07:32:36 UTC
Created attachment 47273 [details]
narrateur.rtf

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/227895

OOo bug may be found at:
http://qa.openoffice.org/issues/show_bug.cgi?id=94499

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/227895/+attachment/2146818/+files/narrateur.rtf && lowriter -nologo narrateur.rtf

the text and image in frames remain.

4) What happens instead is they disappear.
Comment 1 Jean-Baptiste Faure 2011-12-17 16:48:06 UTC
Still there with LO 3.5.0 beta-1 under Ubuntu 10.04 x86_64.

Best regards. JBF
Comment 2 Björn Michaelsen 2011-12-23 12:07:25 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Jean-Baptiste Faure 2011-12-25 22:58:24 UTC
In LO 3.5.0 beta2+ (LibreOffice 3.5.0beta2+ Version ID : 8f03437-7f15fca-1fc8c06-ca8e46d-b96fade) the frames are there but with zero height: I can see two fine lines which can be expanded as frame when I select them.

Miklos: I don't know if you are aware of this bug report. So feel free to reassign if you can't handle it.

Best regards. JBF
Comment 4 Miklos Vajna 2011-12-27 16:58:37 UTC
Reproduced, will take a look.
Comment 5 Miklos Vajna 2012-02-18 13:41:16 UTC
Some frames in the document had exact (and not just minimal) height, this the import of those is fixed in master http://cgit.freedesktop.org/libreoffice/core/commit/?id=e0328096dc21ce12d15db2045074e7860872570f (also got backported to -3-5).

Not closing yet, since this is not the only problem in the attached document.
Comment 6 Miklos Vajna 2013-03-28 10:26:52 UTC
I just checked this again, frames are still wrapped as \nowrap is not imported, the rest looks reasonable.
Comment 7 Miklos Vajna 2013-03-28 10:57:24 UTC
Which actually worked in LO 3.4, marking as a regression.
Comment 8 Commit Notification 2013-03-28 13:53:01 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9c06d2bd253ad6a50141a5b51409dbdffcfd9e6d

fdo#37716 implement import of RTF_NOWRAP



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Miklos Vajna 2013-03-28 15:10:29 UTC
4-0 review: https://gerrit.libreoffice.org/3113
Comment 10 Commit Notification 2013-03-28 15:27:36 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aef51dc739737440c07c11c8cd88015335c5bb8c&h=libreoffice-4-0

fdo#37716 implement import of RTF_NOWRAP


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Robinson Tryon (qubit) 2015-12-17 11:52:01 UTC
Migrating Whiteboard tags to Keywords: (filter:rtf)
Replace rtf_filter -> filter:rtf.
[NinjaEdit]