Bug 37736 - libreoffice math crash when try to write something
Summary: libreoffice math crash when try to write something
Status: RESOLVED DUPLICATE of bug 37668
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-30 01:40 UTC by paolo
Modified: 2011-06-12 19:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description paolo 2011-05-30 01:40:37 UTC
I'm using LibreOffice 3.4.0_rc2 on Debian 7.0 testing & Ubuntu 10.10.
I've downloaded DEBS packages from TDF site.
My problem is when i try to write a formula with LibreOffice Math.
For example if i try to write:

int f(x)*g(x) 

when i'm writing "g" it crashes and closes.

If i try to restore the document it crashes when i'm try to write something!

It happens in both mi GNU/Linux OS!

PS: Thanks for your works, LO 3.4.0 is really fast on GNU/Linux :)
Comment 1 Don't use this account, use tml@iki.fi 2011-05-30 02:47:21 UTC
Jonas, interested?
Comment 2 Rainer Bielefeld Retired 2011-05-30 09:43:11 UTC
NOT reproducible with "LibreOffice 3.4.0RC2  – WIN7  Home Premium  (64bit) German UI [OOO340m1 (Build:12)]" and reporter's example in a new Math document.

Seems to be LINUX specific.
Comment 3 Jonas Finnemann Jensen 2011-05-30 13:11:43 UTC
There's definitely a bug, just writing ( is enough to reproduce it (in master).
I'm guessing there's a bug in the parser, because if you write a closing parentheses before it refreshes the view there's no problem.

This is a pretty serious bug, as it virtually breaks the formula editor.
Comment 4 Jonas Finnemann Jensen 2011-06-01 14:07:05 UTC
I think this is related to the change to OpenSymbol. I suspect that "a" is not in this font, and this leads to problems on line 870 in node.cxx:
SmRect aRect = (SmRect(aTmpDev, &rFormat, C2S("a"),
                                GetFont().GetBorderWidth()));

A quick fix, is to just use alpha instead of "a", i.e. (sal_Unicode)0x3b1
But there's also a lot of other bugs related to this change in font.
Right now the unit test fails with some sort of symbol failure.
Comment 5 Jonas Finnemann Jensen 2011-06-03 11:30:18 UTC
Okay, having looked at the timestamps in the log, I doubt there has been any changes to the font recently.
 - So I'm left with a fix I can't explain :)
Comment 6 Rainer Bielefeld Retired 2011-06-10 02:58:28 UTC
RC2 is bit by bit identical with release version, so separate items in the version picker are useless. Changes have been discussed with Michael Meeks.
Comment 7 LeMoyne Castle 2011-06-12 19:27:12 UTC
Fails in Linux for reporter but succeeds in 64bit Win7 
Fails for me in pre-patch build of 3.4 on Ubu 10.04 32 bit 
Marked as dup of Bug 37668 and assigned to Caolan

*** This bug has been marked as a duplicate of bug 37668 ***