Download it now!
Bug 37753 - libreoffice cannot import/open a valid .xhtml file.
Summary: libreoffice cannot import/open a valid .xhtml file.
Status: RESOLVED DUPLICATE of bug 114428
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HTML-Import
  Show dependency treegraph
 
Reported: 2011-05-30 08:31 UTC by Shlomi Fish
Modified: 2017-12-13 14:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The XHTML file (124.86 KB, application/xml)
2011-05-30 08:33 UTC, Shlomi Fish
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shlomi Fish 2011-05-30 08:31:58 UTC
After I do:

libreoffice3.3 The-Enemy-Hebrew.fiction-text.xhtml

I'm getting an ASCII filter options dialogue. Now the .xhtml file contains an XML declaration («<?xml version="1.0" encoding="UTF-8" standalone="no"?>») and is generated from DocBook/XML and as such is not recognised by libreoffice.

Please make sure that libreoffice open this XHTML file correctly, because I'm tired of XHTML being handled so badly by libreoffice.

Regards,

-- Shlomi Fish
Comment 1 Shlomi Fish 2011-05-30 08:33:19 UTC
Created attachment 47319 [details]
The XHTML file

The XHTML file that is not handled proprely.
Comment 2 Björn Michaelsen 2011-12-23 12:04:26 UTC Comment hidden (obsolete)
Comment 3 Shlomi Fish 2011-12-24 00:34:04 UTC
Can still reproduce with /opt/lodev3.5/program/soffice .

Regards,

-- Shlomi Fish
Comment 4 Julien Nabet 2012-09-15 06:26:35 UTC
On pc Debian x86-64 with master sources updated today, I made different tests:

1) just open the file
LO doesn't display any popup about filtering, it opens the file showing all the xml tags

2) open the file by telling to LO it's html (plain html, not Calc html or something)
LO displays the file without xml formatting except the first xml tag (<?xml version...)

3) I made the same tests with a brand new file, I've got the same results.
Comment 5 Julien Nabet 2012-09-15 06:35:14 UTC
cedric: from my previous comment, I wonder several things:
- is test 1) an ok by default behaviour?
- shoudn't test 2) display xml declaring, no?

Finally, in open type, should there be a specific XHTML part or should it be added to HTML, HTM?

Any idea?
Comment 6 Cédric Bosdonnat 2014-01-20 08:57:47 UTC
Restricted my LibreOffice hacking area
Comment 7 Joel Madero 2015-05-02 15:42:35 UTC Comment hidden (obsolete)
Comment 8 Shlomi Fish 2015-05-02 16:28:59 UTC
(In reply to Joel Madero from comment #7)
> ** Please read this message in its entirety before responding **
> 
> To make sure we're focusing on the bugs that affect our users today,
> LibreOffice QA is asking bug reporters and confirmers to retest open,
> confirmed bugs which have not been touched for over a year.
> 
> There have been thousands of bug fixes and commits since anyone checked on
> this bug report. During that time, it's possible that the bug has been
> fixed, or the details of the problem have changed. We'd really appreciate
> your help in getting confirmation that the bug is still present.
> 
> If you have time, please do the following:
> 
>    Test to see if the bug is still present on a currently supported version
> of LibreOffice (4.4.2 or later)
>    https://www.libreoffice.org/download/
> 
>    If the bug is present, please leave a comment that includes the version
> of LibreOffice and your operating system, and any changes you see in the bug
> behavior

The bug is still present in libreoffice-writer-4.4.2.2-4.mga5 on Mageia Linux 5 x86-64, and this time what happens is that the XHTML file gets opened with all the markup displayed as plaintext intact.
Comment 9 QA Administrators 2016-09-20 09:38:20 UTC Comment hidden (obsolete)
Comment 10 Shlomi Fish 2016-09-21 16:20:59 UTC
This bug, which I had reported, is still happening on Fedora 24 x86-64 with:

/opt/libreoffice5.2/program/soffice The-Enemy-Hebrew.fiction-text.xhtml

It displays the XML markup of the file as tags inside the editor.
Comment 11 Maxim Monastirsky 2017-12-13 14:21:32 UTC

*** This bug has been marked as a duplicate of bug 114428 ***