Bug 37791 - Insert selected word in the Find bar by Ctrl F
Summary: Insert selected word in the Find bar by Ctrl F
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: Other All
: medium enhancement
Assignee: Tamás Zolnai
URL:
Whiteboard: target:3.7.0 target:3.6.1
Keywords:
: 49706 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-31 07:26 UTC by clio
Modified: 2012-12-16 18:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description clio 2011-05-31 07:26:47 UTC
Select a text in Writer, press Ctrl F: the find bar is empty.
The same operation with Ctrl Alt F automatically inserts into the search field.
Comment 1 Rainer Bielefeld Retired 2011-06-10 02:57:59 UTC
RC2 is bit by bit identical with release version, so separate items in the version picker are useless. Changes have been discussed with Michael Meeks.
Comment 2 Andras Timar 2012-08-07 08:32:13 UTC
http://cgit.freedesktop.org/libreoffice/core/commit/?id=2b92546ee3aa3d56f64c68ff3e8e782b3c56dba4

fdo#49750 findbar: try to fill empty textfield with selected text

This commit partially fixed the problem. However, I think we should mimic the behaviour of Firefox's Find bar.

1. Select text in the document when Find bar is visible and text box is empty. Press Ctrl+F.
   Expected result: Text box on Find bar contains the selected text. 
   Note: It works as expected in master.

2. Select text in the document when Find bar is not visible. Press Ctrl+F.
   Expected result: Find bar appears with the selected text

3. Select text in the document when Findbar is visible and text box is not empty. Press Ctrl+F.
   Expected result: Text box on Find bar contains the selected text, not the previous content.
Comment 3 Not Assigned 2012-08-10 09:10:36 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=31b18677987eb82169730750670faf8409206e8c

fdo#37791 Insert selected text to Findbar by Ctrl F
Comment 4 Not Assigned 2012-08-10 19:56:23 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b68ad0ba9ceb8bdfc9fc3a3211c254824d38c267&g=libreoffice-3-6

fdo#37791 Insert selected text to Findbar by Ctrl F


It will be available in LibreOffice 3.6.1.
Comment 5 Roman Eisele 2012-08-17 15:53:41 UTC
*** Bug 49706 has been marked as a duplicate of this bug. ***
Comment 6 royerjy 2012-12-16 18:40:11 UTC
Verified with 4.0.0.beta1 on XP SP3. Selection is copied in find bar by Ctrl+F. Ok.