Bug 37937 - Saving file dialog, no warning about restricted chars in filename
Summary: Saving file dialog, no warning about restricted chars in filename
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All Windows (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Desktop-Integration Save
  Show dependency treegraph
 
Reported: 2011-06-04 19:37 UTC by Michal (JabLuszko) Karwowski
Modified: 2019-10-09 02:29 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michal (JabLuszko) Karwowski 2011-06-04 19:37:39 UTC
Windows have some restrictions about chars in the filenames:
http://msdn.microsoft.com/en-us/library/aa368590(v=vs.85).aspx

Reproduce: Open any LibreOffice application, go to File->Save as, type in "File name:" field:
test_/.odg
test_|.odg
test_>.odg
test_<.odg
test_:.odg
test_".odg
You get proper warning that LO can't save the file -> http://wstaw.org/m/2011/06/05/1.png


Bugs:
Filenames: "test_?.odg" or "test_*.odg" -> is not showing any kind of warning nor saving file. I guess it is related to the regexp/filter files stuff with Windows Dialogs (for example typing *.txt should show only .txt files), but it would be nice that LO would generate some kind of warning for users. Someone just tried to save file named "Questions?.odt" and reported "I can't save a file, nothing happends!".

Filename: "test_\.odg" is generating diffrent warning - related to the path: http://wstaw.org/m/2011/06/05/2.png I am not sure that how LO should react to the filenames with \ in name.

Filename: "\test_.odg" saves file in the C:\ rather than place where you pick it via mouse (Let's say I pick up: "C:\Documents\MyDocuments\blallblblalbla\LO\files\"). No idea if it could be harmful on Linux machines where \ is root directory ;)

LibreOffice installed via LibO_3.3.2_Win_x86_install_multi on Windows 7
Comment 1 Björn Michaelsen 2011-12-23 12:07:28 UTC Comment hidden (obsolete)
Comment 2 Florian Reisinger 2012-08-14 14:04:31 UTC Comment hidden (obsolete)
Comment 3 Florian Reisinger 2012-08-14 14:05:21 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:09:48 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:11:46 UTC Comment hidden (obsolete)
Comment 6 Florian Reisinger 2012-08-15 18:17:48 UTC
Works with LO 3.6
Comment 7 Urmas 2012-08-16 05:52:22 UTC
No, it doesn't. Try other characters than / and :.
Comment 8 Joel Madero 2014-11-04 03:41:17 UTC
Never confirmed by QA team - moving to UNCONFIRMED.
Comment 9 Urmas 2014-11-09 11:17:45 UTC
Confirmed in 4.4 master.
Comment 10 QA Administrators 2015-12-20 16:20:43 UTC Comment hidden (obsolete)
Comment 11 Michal (JabLuszko) Karwowski 2015-12-20 16:53:53 UTC
Still the same behavior. 
Version: 5.0.4.2
Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
Locale: pl-PL (pl_PL)
Windows 10

Nothing happens when you try to save file with * or ? in name. Literally nothing. Examples:
test*test.odt
questions?.odt

Still interpreting \ as root folder, example:
\test.odt tries to save in C:\. te\st.odt says path invalid.
Comment 12 QA Administrators 2017-09-01 11:20:43 UTC Comment hidden (obsolete)
Comment 13 Thomas Lendo 2018-10-08 07:28:33 UTC
Still reproducible.

Version: 6.2.0.0.alpha0+ (x64)
Build ID: e46f8a9a4e3c5b0542c0813b476b449f3af8d607
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-07_23:36:50
Locale: de-AT (de_AT); Calc: CL
Comment 14 QA Administrators 2019-10-09 02:29:05 UTC
Dear Michal (JabLuszko) Karwowski,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug