Bug Hunting Session
Bug 37942 - some formulas not recognized
Summary: some formulas not recognized
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.4.0 Beta4
Hardware: x86 (IA32) All
: high critical
Assignee: Kohei Yoshida
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-05 00:12 UTC by Denham
Modified: 2011-10-29 07:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
A spreadsheet produced in LibreOffice which shows the formulas as faulty. (37.64 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-06-05 02:09 UTC, Denham
Details
Appearance of spreadsheet when using LibreOffice (38.93 KB, image/png)
2011-06-05 02:10 UTC, Denham
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Denham 2011-06-05 00:12:33 UTC
The Excel-type formula =IF((G19+H19)>0,(G19-H19),"") (which runs correctly in OpenOffice) causes a #VALUE! error.

Denham
Comment 1 vitriol 2011-06-05 00:24:22 UTC
In LibO/OOo normally you have to use a semicolon as parameters separator, not a comma:

=IF((G19+H19)>0;(G19-H19);"")
Comment 2 Denham 2011-06-05 00:32:27 UTC
That is correct. But when you try to change the comma to a semicolon it is
not accepted and changes back to a comma (and the error).
The funny thing is that when I open the document in Excel on a WINDOWS
machine, I see the comma as a semicolon.
Regards, Denham

On Sun, Jun 5, 2011 at 12:54 PM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=37942
>
> --- Comment #1 from vitriol <vitriol_vitriol@katamail.com> 2011-06-05
> 00:24:22 PDT ---
> In LibO/OOo normally you have to use a semicolon as parameters separator,
> not a
> comma:
>
> =IF((G19+H19)>0;(G19-H19);"")
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 3 vitriol 2011-06-05 00:39:04 UTC
(In reply to comment #2)

> That is correct. But when you try to change the comma to a semicolon it is
> not accepted and changes back to a comma (and the error).

I'm not able to reproduce this behavior with version 3.4.0 under Win7.
Comment 4 Denham 2011-06-05 00:43:55 UTC
I am using Ubuntu 11.4. It  must be that the bug is somewhere in Ubuntu. I
also have noticed that there is no problem when running the same document
through Excel on Windows XP.
Denham

On Sun, Jun 5, 2011 at 1:09 PM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=37942
>
> --- Comment #3 from vitriol <vitriol_vitriol@katamail.com> 2011-06-05
> 00:39:04 PDT ---
> (In reply to comment #2)
>
> > That is correct. But when you try to change the comma to a semicolon it
> is
> > not accepted and changes back to a comma (and the error).
>
> I'm not able to reproduce this behavior with version 3.4.0 under Win7.
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 5 vitriol 2011-06-05 01:50:25 UTC
Maybe relater to Bug 37860?

@Denham
Please, attach the sample document that you have mailed me. I confirm that is a regression.
Comment 6 Denham 2011-06-05 02:09:01 UTC
Created attachment 47546 [details]
A spreadsheet produced in LibreOffice which shows the formulas as faulty.
Comment 7 Denham 2011-06-05 02:10:24 UTC
Created attachment 47547 [details]
Appearance of spreadsheet when using LibreOffice
Comment 8 vitriol 2011-06-05 02:15:59 UTC
I nominate this bug for "LibreOffice 3.4 most annoying bugs".
Comment 9 Denham 2011-06-05 02:40:45 UTC
Well, when you have to fish out an ancient computer running WINDOWS XP from the bottom of some cupboard just to send out an invoice, I guess you could call that 'annoying' ;-)
Denham
Comment 10 Petr Mladek 2011-06-06 03:15:47 UTC
Kohei, could you please have a look?
Comment 11 Kohei Yoshida 2011-06-06 08:05:49 UTC
I'm afraid this is just another manifestation of the unfortunate event as outlined in Bug 37860.  In short, this is not a bug, and the reason and rationale is explained in Bug 37860.

To fix this, please change the "" to 0 in columns G and H.  Then the formulas in column F should work as expected (if I understand the intent of those formulas correctly).
Comment 12 Kohei Yoshida 2011-06-06 08:07:31 UTC
Not a regression.
Comment 13 vitriol 2011-06-06 09:14:02 UTC
(In reply to comment #12)

> Not a regression.

Not a regression? Old documents don't work anymore as expected, therefore *is* a regression!
This behavior (bug, for me...) breaks compatibility with OOo and previous versions of LibO.
Comment 14 Kohei Yoshida 2011-06-06 09:26:49 UTC
(In reply to comment #13)
> (In reply to comment #12)
> 
> > Not a regression.
> 
> Not a regression? Old documents don't work anymore as expected, therefore *is*
> a regression!
> This behavior (bug, for me...) breaks compatibility with OOo and previous
> versions of LibO.

Then I challenge you to come up with a solution (or best compromise) that best serves a wide variety of use cases.  Just saying "fix this for me and break it for others" is a not a great solution I would go for.
Comment 15 vitriol 2011-06-06 09:38:37 UTC
@Kohei Yoshida
What's really wrong in previous behavior?
Comment 16 Kohei Yoshida 2011-06-06 09:43:58 UTC
See Bug 37860 for my explanation.  I won't repeat it here.
Comment 17 Denham 2011-07-01 22:01:10 UTC
Thanks for letting me know that the bug was not a bug. The work-around (to replace the "" with a zero in the If arguments) worked well so I have no complaints. If anyone else is bugged by this non-bug it may be useful to them too.
Entomology was never my strong-point, so you must forgive me from being a bit confused by the difference between bugs and non-bugs.
Denham