Download it now!
Bug 37952 - Doesn't print in landscape mode on envelopes (C5)
Summary: Doesn't print in landscape mode on envelopes (C5)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-05 08:14 UTC by Fabio Varesano
Modified: 2017-03-04 17:59 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
the file which isn't printing correctly (12.02 KB, application/vnd.oasis.opendocument.text)
2011-06-05 08:16 UTC, Fabio Varesano
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Varesano 2011-06-05 08:14:32 UTC
I just upgraded from 3.3.2 to 3.4 final and I'm facing a strange problem.

I usually use LibreOffice to print on C5 envelopes as in the attached file. Basically the text is in landscape mode. 

With 3.3.2 simply printing that would result in correctly placed text on the printed envelope, while on 3.4, no matters how I setup the printer, it always gets printed with the wrong orientation.

As a test I didn't changed the file and downgraded to 3.4 and magically it started printing correctly.

I'm capable of providing further details upon request.


Thanks,

Fabio Varesano
Comment 1 Fabio Varesano 2011-06-05 08:16:13 UTC
Created attachment 47564 [details]
the file which isn't printing correctly
Comment 2 Rainer Bielefeld Retired 2011-06-10 02:57:39 UTC
RC2 is bit by bit identical with release version, so separate items in the version picker are useless. Changes have been discussed with Michael Meeks.
Comment 3 Tom Mannerhagen 2011-06-29 04:24:35 UTC
Hi

I am also experiencing this exact bug.

I am using LibreOffice 3.4.0 OOO340m1 (Build:12) on Fedora 14 and printing on a Canon Pixma iP2600 printer using proprietary drivers from Canon (2.90).
I did not see the pattern before (been switching between computers, Fedora-versions and L.O-versions) but it seems like with 3.4.0 this strange issue appears.

When printing C5 envelopes the output is always (regardless of million seetings in the page format, printer settings (from L.O), driver settings (from printer admin tool)) - the output is Portrait.

If I print to PDF or save as PDF, open with Evince, I can print Landscape without problems.

Strange problem!!
Also a bit annoying.

BR

Tom
Comment 4 Fabio Varesano 2011-06-29 04:43:19 UTC
Tom, good to know I'm not alone.. now can we have some developers love?

Btw, in my initial comment: "As a test I didn't changed the file and downgraded to 3.4 and magically it started printing correctly.".. I obviously meant downgrading to 3.3.2.
Comment 5 Jeremy M 2011-07-09 16:30:41 UTC
Bug still present in 3.4.1 release, using Arch Linux (Debian). Problem does not exist in Windows based 3.4.1 release. I'm using C10 envelope formatting and the landscaping refuses to work in the proper orientation. Older version also worked fine- in fact used the same document template I created with 3.2
Comment 6 Paul Brown 2011-11-25 05:01:25 UTC
Bug still present in LibreOffice 3.4.4 Fedora 16 64 bits. In this case, refuses to print correct orientation of DL Envelopes, despite showing up correctly in preview window.
Comment 7 Björn Michaelsen 2011-12-23 12:05:48 UTC Comment hidden (obsolete)
Comment 8 Fabio Varesano 2012-01-05 09:28:18 UTC
Bug still present in 3.4.4, Archlinux 64 bit.

Workaround in my case: File -> Printer Settings -> Printer Properties -> Printer the set printer language to Postscript level 1. 

Thanks to the hints in http://forums.opensuse.org/english/get-technical-help-here/applications/466824-libreoffice-3-4-2-cant-print-c5-envelopes-landscape.html
Comment 9 Ken 2012-01-15 12:06:40 UTC
This bug is confirmed for LibreOffice 3.4.4 AFTER UPDATE to Fedora 16 (Linux 3.1.8-2.fc16.x86_64 #1 SMP Sat Jan 7 13:35:24 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux). Writer refuses to print landscape on ANY size paper.

The bug is also present when printing from Firefox.

Another workaround: if you print to file first (.ps), then dump the PS file to printer, Landscape works.

Seems like mismatch between application and CUPS or something?
Comment 10 Ken 2012-01-15 12:15:58 UTC
The workaround setting "File -> Printer Settings -> Properties ->
Device tab -> Printer Language Type" to [PostScript (Level from Driver)] works for me.

Why is it set to PDF by default?
Comment 11 sasha.libreoffice 2012-02-21 05:23:39 UTC
I also have similar problem with printing:
Please, verify Bug 44664 - Calc PRINTING: printer prints Landscape page orientation as Portrait
Comment 12 stihia 2012-04-11 06:30:40 UTC
OS: Windows 7 Ultimate 32-bit
LibreOffice 3.5.2.2
Printer: Epson SX130

Same problem here. The only envelope I have problems with is C5 Envelope. After I select this format the preview window in the left show me the Letter format.

There is no problem at all printing on C5 from Adobe Reader, IrfanView, Mozilla Firefox. Again, there's no problem at all printing even from LibreOffice on other envelope formats (C4, DL, #10, etc.).
I don't recall having this problem with older versions of LibreOffice, BUT at that time I was using Lexmark X1270 instead of Epson SX130.
Anyhow, the printer seems not to be related with this bug.
Comment 13 sasha.libreoffice 2012-04-30 01:50:34 UTC
@ stihia
See also here:
Bug 44932 - Writer PRINTING: Printing on bottom of envelopes appears bottom-up
Comment 14 Christian Fischer 2012-05-29 02:06:25 UTC
hi
I work with linux 3 (Mandriva 2010.2 ), LibreOffice 3.4.6 OOO340m1 (Build:602)
HP Laserjet 1220
hplip 3.11.5-1.3mdv2010.2
trying envelop DL:

Error : no print if  language of printer is "PDF"

If language of printer is postscript all is good ( printer is local )

It is critical for me :

Libreoffice do not remember "language printer is postscript " that print all document. 
Language printer "PDF" by default do not print many files.

So Libreoffice is too difficult to use !
Comment 15 sasha.libreoffice 2012-05-29 03:11:10 UTC
@ Christian Fischer
Use workaround from bug 44664
Comment 16 Samuel Mehrbrodt (CIB) 2013-10-03 14:01:17 UTC
Does this problem still exist in Version 4.1?
Comment 17 QA Administrators 2014-05-17 00:33:57 UTC
Dear Bug Submitter,

Please read the entire message before proceeding.

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 18 QA Administrators 2014-06-01 20:29:57 UTC Comment hidden (obsolete)
Comment 19 Jeremy M 2017-02-25 22:00:09 UTC
This is still present in 5.3.0. Always wants to print a C5 envelope after selecting #10. I'm not sure what else you need? Just try to print a #10 envelope for yourself (Windows or Linux, it's quite obvious it doesn't work). If you need a specific detail, I'm happy to provide it.
Comment 20 Buovjaga 2017-03-04 17:59:49 UTC
First: the original problem reported by Fabio does not appear: the orientation stays landscape in Print dialog. However, it is the wrong dimensions.

Second: Jeremy's last comment is referring to a completely different issue. There are several similar reports:
https://bugs.documentfoundation.org/buglist.cgi?list_id=680643&query_format=advanced&resolution=---&short_desc=envelope%20print&short_desc_type=allwordssubstr

Let's close this.