Bug Hunting Session
Bug 37955 - Page scrolls after click on 'Format paintbrush' when mouse pointer reaches document text
Summary: Page scrolls after click on 'Format paintbrush' when mouse pointer reaches d...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-05 10:24 UTC by Rainer Bielefeld Retired
Modified: 2015-03-07 09:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document, pls. see original report! (39.73 KB, application/vnd.oasis.opendocument.text)
2011-06-05 10:24 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-06-05 10:24:00 UTC
Created attachment 47566 [details]
Sample document, pls. see original report!

I observed the problem during my tests for "
Bug 37583 - EDITING: 'Format paintbrush' causes scroll from last to first page"
with "LibreOffice 3.4.0RC2  – WIN7  Home Premium  (64bit) English UI [OOO340m1 (Build:12)]".

Steps to reproduce: 

1. Open "Sample.odt" from LibO Start Center
2. <ctrl+End> to scroll to document end
3. Select last word "accumsan" by cobule click
4. Click Icon 'Format Paintbrush' in Standard Toolbar
5. Move cursor down to text contents
   Expected: mouse pointer changes to paint bucket, nothing else
   Actually: mouse pointer changes to paint bucket, text scrolls / jumps 

If you frequently move mouse pointer from text contents to toolbar and back, you will see a jump (scroll) nearby every time. From particular positions of the highlighted format source even the scrolling makes the source invisible.

I see the same with OOo 3.1.1
Comment 1 Stephan Zietsman 2011-06-06 00:33:24 UTC
(In reply to comment #0)
> If you frequently move mouse pointer from text contents to toolbar and back,
> you will see a jump (scroll) nearby every time. From particular positions of
> the highlighted format source even the scrolling makes the source invisible.
> 
> I see the same with OOo 3.1.1

Can confirm with LibreOfficePortable 3.3.2 (as downloaded from portableapps.com) running on Win7 64 bit.  A few additional comments:

I notice the same behaviour with the "Highlighting" paintbrush, if no text is selected prior to using the highlighting paintbrush.

It seems to autoscroll, as would be expected if you were dragging the format/highlighting brush.  I.e. if you select the brush, click-and-hold left mouse button (on some text) and drag the mouse up or down, then it should scroll up or down when you reach the top or bottom.  I suspect this behaviour just has a small bug (making it scroll when NOT dragging), probably a candidate for EasyHacks?  Can anyone comment on this?

About:
LibreOffice 3.3.2 
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2
Comment 2 Rainer Bielefeld Retired 2011-06-06 04:23:13 UTC
NEW due to Comment 1
Comment 3 Rainer Bielefeld Retired 2011-06-10 02:58:30 UTC
RC2 is bit by bit identical with release version, so separate items in the version picker are useless. Changes have been discussed with Michael Meeks.
Comment 4 sasha.libreoffice 2011-06-14 23:18:02 UTC
when Paintbrush selected, text scrolls autumatically
when we move mouse over top or bottom of screen of text (few millimeters near
horizontal rule on top or status window on bottom)
Text scrolls too fast and it looks like it jumps.
To solve this problem undock standard toolbar (where Format Paintbrush) and
dock it on left or right margin of screen or leave it floating

IMHO autoscroll should be initially disabled and begin working when mouse placed inside of text. This will prevent unexpecting jumping.
Or my added to tooltip recomendation to place standard toolbar on left or right margin of screen or leave it floating
Comment 5 johnoradcliffe 2011-06-17 03:47:58 UTC
@ sasha.libreoffice@gmail.com - this describes one of the LO Writer problems i get.
I'm using a Linux Fedora version 3.3.2.2-9.fc15 at the moment although it has been there 
for about 2 years going back to OO using my AMD 64bit system.
It appears similar but not quite the same as the OP's problem as i read it.
I cannot yet find where to disable autoscroll ?
Moving or leaving the toolbar floating does not cure the problem on my system.
Comment 6 sasha.libreoffice 2011-06-17 04:32:05 UTC
It was just idea that when toolbar is placed somewhere in middle of screen then mouse cursor never appears at top or bottom of screen and therefore text will not scroll. As we can see, this idea not works.

If Format paintbrush used very often, my be better to create some style and assign them to keyboard shortcut? Then we can change formatting by one click.
Comment 7 Björn Michaelsen 2011-12-23 12:04:23 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 8 sasha.libreoffice 2011-12-25 23:54:50 UTC
reproduced on LibO 3.5.0 beta 1
Comment 9 A (Andy) 2013-04-27 18:06:11 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

but one remark: I interpreted Step 5 as: after activating FORMAT PAINTBRUSH move the mouse pointer down to the text, but not the cursor by using an arrow key
Comment 10 QA Administrators 2015-03-04 02:23:34 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 11 Jean-Baptiste Faure 2015-03-07 09:06:20 UTC
For me autoscroll with paintbrush cursor is not a bug but a feature. :-)

Closing as NotABug. Please, if you disagree, open a new bug / enhancement proposing to remove this autoscroll.

Best regards. JBF