Bug Hunting Session
Bug 37978 - Date formatting in Spreadsheet is inconsistent
Summary: Date formatting in Spreadsheet is inconsistent
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: high major
Assignee: Eike Rathke
URL:
Whiteboard:
Keywords:
: 41042 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-06 03:00 UTC by marc sinclair
Modified: 2011-12-31 07:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marc sinclair 2011-06-06 03:00:28 UTC
After nearly TEN YEAR of this BUG in Open Office - perhaps Libreoffice has the will to do something about it -

The issue is that date handling in the spreadsheet is a dogs breakfast.

1 - Open a new Spreadsheet on a machine with ISO dates as the native date
format

2 - Enter the (valid) date 2011-06-05into a cell

3 - Press return

4 - cell shows 05/06/11 (whatever that means, is it May, June or
November?)

5 - Select the cell

6 - The Input line now says 05/06/2011 (aha! so it is either May or June)

7 - Double click the cell and it changes to the second format 02/01/2008 
trying to edit in this unusual format is problematic and almost useless for practical puposes.

Marc
Comment 1 marc sinclair 2011-06-06 03:06:13 UTC
After nearly TEN YEAR of this BUG in Open Office - perhaps Libreoffice has the
will to do something about it -

The issue is that date handling in the spreadsheet is a dogs breakfast.

1 - Open a new Spreadsheet on a machine with ISO dates as the native date
format

2 - Enter the (valid) date 2011-06-05into a cell

3 - Press return

4 - cell shows 05/06/11 (whatever that means, is it May, June or
November?)

5 - Select the cell

6 - The Input line now says 05/06/2011 (aha! so it is either May or June)

7 - Double click the cell and it changes to the second format 05/06/2011#
trying to edit in this unusual format is problematic and almost useless for
practical purposes.

Marc
Comment 2 Eike Rathke 2011-12-21 09:04:06 UTC
*** Bug 41042 has been marked as a duplicate of this bug. ***
Comment 4 Dotan Cohen 2011-12-21 10:42:27 UTC
> Fixed in master
> 

I cannot believe it! This has been one of three or four serious show-stoppers in OOo for the organizations where I have integrated OOo. I really thought that we would never see it fixed.

Eike, your work is very, very appreciated! Thank you!
Comment 5 Mike Evans 2011-12-22 03:09:12 UTC
Thank you for fixing this bug.  I too have been waiting many years for this fix.