Bug Hunting Session
Bug 38067 - Maximum CPU load opening or scrolling particular documents imported from WORD
Summary: Maximum CPU load opening or scrolling particular documents imported from WORD
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks:
 
Reported: 2011-06-08 01:18 UTC by Thomas Thym
Modified: 2016-12-20 14:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
This file was migrated from Word 2000 and edited with OpenOffice 3.3.0. It is not possible to open with LibreOffice (system hangs). (109.56 KB, application/vnd.oasis.opendocument.text)
2011-06-08 01:18 UTC, Thomas Thym
Details
second file: LO hangs when srolling / clicking into a table (111.33 KB, application/vnd.oasis.opendocument.text)
2011-06-08 01:21 UTC, Thomas Thym
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Thym 2011-06-08 01:18:47 UTC
Created attachment 47704 [details]
This file was migrated from Word 2000 and edited with OpenOffice 3.3.0. It is not possible to open with LibreOffice (system hangs).

At our company we are migrating from MS Office 2000 to LibreOffice (3.3.2 and OpenOffice 3.2.0). The following files were migrated from Word 2000. After a while working with those they crash on opening. Our employees like working with tables and tables in tables and inserting pictures into those tables. This might cause the trouble. 

The first file attached does not open, the second hangs when you scroll and click into the second table from the bottom.

A short note about possible solutions and the time frame would help me. It's really important to keep the migration project alive.

Thanks for your work.
Comment 1 Thomas Thym 2011-06-08 01:21:16 UTC
Created attachment 47705 [details]
second file: LO hangs when srolling / clicking into a table

Scroll to the second table from bottom called "Kondenswassertest" and click into it. => LO hangs.
Comment 2 Thomas Thym 2011-06-08 02:30:24 UTC
Same behaviour with LibreOffice 3.4.0.
Comment 3 Rainer Bielefeld Retired 2011-06-08 05:39:23 UTC
[Reproducible] with reporter'e "S_532 Konkurrenzanalyse 2K. PU-Grundierungen (Grundierfüller).odt" and "LibreOffice 3.4.0  – WIN7  Home Premium  (64bit) English UI [OOO340m1 (Build:12)]".

Both documents open fine when I dobleclick in WIN explorer, in document 
"S_532 ..." I see the problem that LibO will stop responding when I scroll down (using scroll slider) and reach page 5. 

OOo 3.1.1 also stops responding for several seconds reaching the same position, but after a short time problem disappears and from now on the document can be used without problems.

Some tests with switching off auto spell check or auto correct did not solve the problem.

We might have 2 problems:
1. incorrect conversion .doc -> .odt
2. Crash problem

@Thomas Thym
Can you please contribute some more information how those documents have been created? Can you please also attach the source .doc documents?
Comment 4 Rainer Bielefeld Retired 2011-06-08 05:51:00 UTC
BTW, Thomas Thym:
Can you confirm
"Bug 37206 - Recovery window shows error report text"?
Comment 5 Thomas Thym 2011-06-08 06:59:51 UTC
Thanks for your quick response. I tried to reproduce the error with the .doc files he though he was using, but without success. (Once you are looking forward to a crash and nothing is happening.)
I will have a look into that tomorrow. Thanks for your help.
Comment 6 Andras Timar 2011-06-09 05:54:54 UTC
I could not reproduce the crash but I saw serious slowdown of application.
Comment 7 Michael Meeks 2011-06-09 08:02:23 UTC
Not reproducible under Linux - even under valgrind; though I got this:

==16687== 
Error: File /data/opt/libreoffice/libreoffice-3-4/clone/libs-gui/unotools/source/config/configitem.cxx, Line 584: XHierarchicalNameAccess: Other/IsSquaredPageModeOther/ApplyCharUnit
/org.openoffice.Office.Writer/Layout/Other/IsSquaredPageModeOther/ApplyCharUnit
Backtrace: [0] /data/opt/TTInstall/program/../basis-link/program/libutlli.so: _ZN3utl10ConfigItem13GetPropertiesERKN3com3sun4star3uno8SequenceIN3rtl8OUStringEEE+0x517
Backtrace: [1] /data/opt/TTInstall/program/../basis-link/program/libswli.so: ???+0x6372f8
Backtrace: [2] /data/opt/TTInstall/program/../basis-link/program/libswli.so: ???+0x6379be

but its clearly not fatal (perhaps I should re-compile utl without debug though).
Comment 8 Thomas Thym 2011-06-09 08:56:28 UTC
Hi all,

today we tried again to reproduce the bug, creating a crashing document. Again with no success. Is it useful if I attach the source files? They were heavily modified. Is there anything else we could do to help you?

Cheers and thanks,
Thomas
Comment 9 Thomas Thym 2011-06-09 09:06:00 UTC
I just opened the document on my openSUSE laptop (LibreOffice 3.3.1 OOO330m19) with rather the same behavior. After a while very high cpu usage I could see the text in the first 5 columns as well. Clicking into the document restarted the high cpu usage and the text in the first 5 columns disappeared again.
Comment 10 Rainer Bielefeld Retired 2011-06-09 11:24:43 UTC
I believe currently we should check the reproducible high CPU load here.

@Thomas Thym:
Currently this only has low priority because we have no information that lots of users might be affected.

Here we urgently need information concerning your OS. Currently it looks like "WIN only"?

I recommend to file a second report concerning a possible import problem (causing damaged documents). For that we need a source.doc, result.odt (showing the problems reported here) and a good description concerning the import process. So someone can check whether the import process creates damaged documents. 

I recommend to read  hints on <http://wiki.documentfoundation.org/BugReport>, those hints might help you to create an optimum report with minimum costs.

@Andras Timar:
With what OS did you observe the slowdown?
Please feel free to leave CC after having left information
Comment 11 Rainer Bielefeld Retired 2011-06-09 22:11:20 UTC
OS -> ALL due to Comment 9

@Cédric:
Please feel free to reassign if it's not your area!
Comment 12 Andras Timar 2011-06-09 22:13:36 UTC
(In reply to comment #10)

> @Andras Timar:
> With what OS did you observe the slowdown?

Linux 32-bit and Windows.
Comment 13 Julian Rüger 2011-08-18 00:24:05 UTC
I just tested the attached document with LO 3.3.3 on Ubuntu natty 64-bit.

The first ("not possible to open") seems to work fine, no problems or even slowdown as far as I can tell.

The second one though, caused 100% CPU when scrolling below the color-filled cells.

Hope this helps! Best regards,
Julian
Comment 14 Rainer Bielefeld Retired 2012-04-03 13:30:23 UTC
I still see the scroll problem with and  with "LibreOffice 3.5.2.2 German UI/Locale [Build-ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f] on German WIN7 Home Premium (64bit) 

Currently I see not many users and / or documents affected, so I remove this one from MAB 3.4.

If you find that this affects a bigger number of documents please feel free to add  to “Bug 37361 LibreOffice 3.5 most annoying bugs”
Comment 15 Rainer Bielefeld Retired 2012-04-03 13:32:32 UTC
Opps, wanted to say "with S_532 Konkurrenzanalyse 2K. PU-Grundierungen (Grundierfüller)" and 3.5.2
Comment 16 Julien Nabet 2012-10-12 23:35:54 UTC
On pc Debian x86-64 with master sources updated today, here what I got:
File S528 PolyAmol:
- opening OK
- scroll OK

File S532...:
- opening OK
- scroll KO from page 3
infinite loop with this:
warn:legacy.osl:29699:1:/home/julien/compile-libreoffice/libo/sw/source/core/layout/tabfrm.cxx:2606: debug assertion: <SwTabFrm::MakeAll()> - format of table lowers suppressed by fix i44910
Comment 17 Julien Nabet 2014-01-04 09:21:18 UTC
On pc Debian x86-64 with master sources updated yesterday, I reproduced the behaviour of my last comment, only the number line changed.
warn:legacy.osl:7382:1:sw/source/core/layout/tabfrm.cxx:2633: debug assertion: <SwTabFrm::MakeAll()> - format of table lowers suppressed by fix i44910

Since no one is assigned, I put it at NEW.
Comment 18 Philipp Weissenbacher 2014-06-15 09:24:37 UTC
Can still confirm on Win 8.1, LO 4.2.4.2.
Comment 19 QA Administrators 2015-07-18 17:44:15 UTC Comment hidden (obsolete)
Comment 20 Buovjaga 2015-10-23 08:30:51 UTC
Confirmed slowdowns.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: fcc2415ade6ae93710bbbda9f7e163045e323105
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-21_16:55:13
Locale: fi-FI (fi_FI)
Comment 21 Robinson Tryon (qubit) 2015-12-09 18:07:49 UTC Comment hidden (obsolete)
Comment 22 Telesto 2016-12-20 13:36:38 UTC
No repro with:
Version: 5.4.0.0.alpha0+
Build ID: 53edf60c4ce6ed32f87471e018878c40b788005a
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-18_06:57:59
Locale: nl-NL (nl_NL); Calc: CL
Comment 23 Buovjaga 2016-12-20 14:26:34 UTC
(In reply to Julian Rüger from comment #13)
> The second one though, caused 100% CPU when scrolling below the color-filled
> cells.

Ok now I do not see the CPU rise for this, let's close.

Version: 5.4.0.0.alpha0+
Build ID: 53edf60c4ce6ed32f87471e018878c40b788005a
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-12-18_07:01:05
Locale: fi-FI (fi_FI); Calc: group