Bug 38139 - Copy and paste with mouse between spreadsheets on different computers results in OLE object
Summary: Copy and paste with mouse between spreadsheets on different computers results...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: x86-64 (AMD64) Linux (All)
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Clipboard
  Show dependency treegraph
 
Reported: 2011-06-10 01:13 UTC by Frank Steiner
Modified: 2021-10-10 03:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Steiner 2011-06-10 01:13:29 UTC
We see the problem since OpenOffice 3.2 (maybe 3.1, not in 3.0) and now in
libreoffice 3.3.1.2 in SuSE Linux Enterprise Desktop 11 SP1 when we copy and
paste from one libreoffice spreadsheed running on the local PC to a libreoffice
spreadsheed running on a remote PC (or vice versa)

We mark some cells with the left mouse key on the local PC. When we copy with
Ctrl-C and press Ctrl-V in the remote spreadsheed, the data is inserted as
expected. 
When we insert on the remote spreadsheed with the middle mouse key
(the standard linux way for copy & paste) while the cells are stilled marked
(otherwise nothing would be pasted), we get an OLE object. The result is the same as described in bug #31077 and it looks exactly as in the attached screenshot in this bug (https://bugs.freedesktop.org/attachment.cgi?id=39809). 

Copy&Paste with left+middle mouse keys works fine within the same or between
two spreadsheets when both are running on the local PC or both on the remote
PC. Thus, only copying+pasting between two spreadsheets on two different PCs
(both could be on different remote PCs, too) and only when pasting with the
middle mouse key, the data is pasted as OLE object. 

Maybe the workaround in bug #31077 fixed only the Ctrl-C/Ctrl-V code and must be applied to the code part that handles mouse pasting for linux?

cu,
Frank
Comment 1 Björn Michaelsen 2011-12-23 12:21:56 UTC Comment hidden (obsolete)
Comment 2 Frank Steiner 2012-01-09 01:21:18 UTC
The bug still exists in the same way in LOdev 3.5.0beta2.
Comment 3 QA Administrators 2014-06-25 17:38:02 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2015-07-18 17:43:16 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-10-17 13:30:43 UTC
Never confirmed by QA.

Is this still a problem with LibreOffice 5? No help from Paste special?

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 6 Frank Steiner 2015-10-19 06:50:07 UTC
The problem still exist and has never gone away during the last years. It is still possible to copy between different instances of libreoffice running on a remote and a local host with Ctrl-C and Ctrl-V. But selecting one or more cells in a spreadsheet with the left mouse button and then just pasting them with the middle mouse button in the other libreoffice window will insert an object and not the text.

Still, selecting and pasting with the mouse does work when done inside the same spreadsheet or between two spreadsheets running on the same (local or remote) host. Just copying between libreoffice windows running on different computers creates the OLE object when pasting with the middle mouse button. Pasting with Ctrl-V always works fine.
Comment 7 mahfiaz 2016-04-17 10:00:01 UTC
What exactly is meant with "running on remote PC"?
Is this VNC, ssh -X or something else?
Comment 8 Frank Steiner 2016-04-18 06:27:27 UTC
We are seeing this with "ssh -X".
Comment 9 mahfiaz 2016-04-23 10:35:37 UTC
Thank you for reporting back.

I can confirm this with 5.0.5.2 on both machines running Ubuntu Linux.

1. So I did ssh -X user@othermachine
2. Selected some cells with data on the other machine.
3. Middle-click pasted on local machine.
4. OLE object appeared.
Works (doesn't) the same on both directions.

Ctrl+C and Ctrl+V between instances on different machines works just fine.


(Frank, can you also please take a look at https://bugs.documentfoundation.org/show_bug.cgi?id=99466 )
Comment 10 QA Administrators 2017-05-22 13:23:53 UTC Comment hidden (obsolete)
Comment 11 Frank Steiner 2017-05-23 07:09:04 UTC
Still exists, nothing has improved.
Comment 12 QA Administrators 2018-07-02 02:35:54 UTC Comment hidden (obsolete)
Comment 13 Frank Steiner 2018-07-02 06:28:12 UTC
Problem still the same in Version: 6.0.4.2
Comment 14 QA Administrators 2019-10-10 02:40:39 UTC Comment hidden (obsolete)
Comment 15 QA Administrators 2021-10-10 03:44:09 UTC
Dear Frank Steiner,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug