Bug 99466 - Opening about dialog over ssh -X hangs LibO
Summary: Opening about dialog over ssh -X hangs LibO
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: All Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: About-Dialog
  Show dependency treegraph
 
Reported: 2016-04-23 10:34 UTC by mahfiaz
Modified: 2017-07-27 12:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Backtrace of hang (7.16 KB, text/plain)
2016-04-23 10:34 UTC, mahfiaz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mahfiaz 2016-04-23 10:34:12 UTC
Created attachment 124587 [details]
Backtrace of hang

1. Log in to remote computer with ssh -X user@remotemachine
2. Run soffice
3. Open Help → About
Notice the program hanging.
Comment 1 Linus 2016-05-08 17:06:33 UTC
Can't confirm:

Version: 5.0.5.2
Build ID: 00m0(Build:2)
Locale: en-US (en_US.UTF-8)

openSUSE Leap 42.1 x86_64

Also works nicely with recent master build:

Version: 5.2.0.0.alpha1+
Build ID: 0771f36bf5910a8a8103c6575792ca55cf65d5d4
CPU Threads: 4; OS Version: Linux 4.1; UI Render: default; 
Locale: en-US (en_US.UTF-8)
Comment 2 Muhammet Kara 2016-10-14 08:34:58 UTC
Can't confirm on Pardus linux (64 bit)

Version: 5.3.0.0.alpha0+
Build ID: e584bc808b634bf18ba5f7538d598e135b28f090
CPU Threads: 32; OS Version: Linux 3.16; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 3 Thomas Hackert 2016-12-17 13:46:13 UTC
Hello mahfiaz, *,
thank you very much for reporting this bug :) However, I cannot confirm it with

OS: Debian Testing AMD64 (w/ SSH server 1:7.3p1-5) and Debian Testing i686 (w/ SSH client of the same version)

LO: Version: 5.0.0.0.beta3
Build-ID: 96345c15d8ab19c49014f055fe41ba8e1f421e5c
Gebietsschema: de-DE (de_DE.UTF-8)

up to

LO: Version: 5.3.0.0.beta2
Build-ID: a7e30712ad6d8bc9286007b37aa581983e0caba3
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; VCL: gtk2; Layout-Engine: neu; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
(all parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux)

sorry ... :( Just out of interest: Which distro are you using on your server as well as your client?
Have a nice day
Thomas.
Comment 4 Xisco Faulí 2016-12-17 19:51:22 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-06-28 12:37:14 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2017-07-27 12:02:39 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-20170727