Download it now!
Bug 38147 - FILESAVE File Sharing Password protected MS Word document no longer editable after reopen
Summary: FILESAVE File Sharing Password protected MS Word document no longer editable ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 43229 43890 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-10 03:52 UTC by polach
Modified: 2014-12-11 11:29 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
The_file (19.50 KB, application/msword)
2011-06-15 23:00 UTC, polach
Details
odt with forms (10.73 KB, application/vnd.oasis.opendocument.text)
2013-04-13 17:37 UTC, Thomas Arnhold
Details
doc with forms (15.50 KB, application/msword)
2013-04-13 17:38 UTC, Thomas Arnhold
Details

Note You need to log in before you can comment on or make changes to this bug.
Description polach 2011-06-10 03:52:24 UTC
I have protected MS Word (*.doc) document (but changes are allowed and track changes is On) and if I can open it in LibreOffice Writer the document is open in read only mode and I am not able to change it. See the attached file.
Comment 1 tester8 2011-06-14 04:06:28 UTC
There is nothing attached.
Please attach the file.
Comment 2 polach 2011-06-15 23:00:08 UTC
Created attachment 48023 [details]
The_file
Comment 3 polach 2011-07-22 01:11:02 UTC
The problem is still in LibreOffice 3.3.2, 3.3.3, 3.4.0, 3.4.1, 3.4.2 RC1. There is no possibility to edit the .doc document where the protection (described in the first comment of this bug) is activated. MS Word 2003 is working good. Thank you for your interest
Comment 4 Björn Michaelsen 2011-12-23 12:28:35 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 sasha.libreoffice 2012-01-06 02:41:18 UTC
reproducible in LibO 3.5.0 beta 1 on Fedora 64 bit
Steps to reproduce:
0. Open file from attachment in Writer
1. Press button "Edit file" in main toolbar
2. enter password 1111 there
3. edit document
4. save
5. File->Reload
6. do steps 1,2,3
Expected: document modifies
Actually: dialog appears that tells that read-only file can not be modified.
Comment 6 Rainer Bielefeld Retired 2012-04-06 01:46:31 UTC
Modified Version due to Comment 3 and own tests

I believe the problem is more simple.

Steps to reproduce with  "LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:6) tag libreoffice-3.3.0.4]" :

1. Open attached sample
2. Menu 'File -> Save as'
3. Modify File name to "Track_changes2.doc
4. Click 'Save with Password', <Save>
   > Set password dialog appears
5. Click 'More options', -> 'Open file read-only'
6. Enter and confirm file sharing password "123456", <ok>
7. Save as current document format .doc
8. close -> reopen via recent documents
   > As expected: read-only
9. Click in Task bar icon "Edit File", insert password, ok
   > As expected: additional edit task bar appear
10. Click behind end of first line in document, try to type something
    expected: typed text appears
    actual: Message "Readonly Content cannot be changed. 
            No modifications will be accepted"

A new test showed that it's even more simple:
0. Open New writer document
1. Type "qwertz" and save as sample0.odt
2. Menu 'File -> Save as -> sample1.doc (Word97)'
3. Click 'Save with Password', <Save>
  > Set password dialog appears
4. Click 'More options', -> 'Open file read-only'
5. Enter and confirm file sharing password "123456", <ok>
6. Save as current document format .doc
7. close -> reopen via recent documents
   > As expected: read-only
8. Click in Task bar icon "Edit File", insert password, ok
   > As expected: additional edit task bar appear
9. Click behind end of first line in document, try to type something
    expected: typed text appears
    actual: Message "Readonly Content cannot be changed. 
            No modifications will be accepted"

That worked fine with OOo 3.3, but broken starting with first LibO Version
No problem when I save document as .odt and then redo tests starting with 1

This one might be related to /Dup of
"43890 - Cannot edit .doc saved from a .docx that had a password protection for editing"
"Bug 43229 - Unable to un-protect password protected MS-Word .doc document"

MAJOR because the problem seems to cause dataloss

@all: 
do you agree with my simplified bug description?
It would be interesting to know whether MSWORD will bi able to edit document.

@Michael:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug
Comment 7 Rainer Bielefeld Retired 2012-04-06 01:49:14 UTC
*** Bug 43890 has been marked as a duplicate of this bug. ***
Comment 8 Rainer Bielefeld Retired 2012-04-06 01:50:15 UTC
*** Bug 43229 has been marked as a duplicate of this bug. ***
Comment 9 Thomas Arnhold 2013-04-12 16:55:39 UTC
I'll give it a try :)
Comment 10 Thomas Arnhold 2013-04-13 17:37:23 UTC
Created attachment 77924 [details]
odt with forms

odt file with forms (password: 1234)
Comment 11 Thomas Arnhold 2013-04-13 17:38:23 UTC
Created attachment 77925 [details]
doc with forms

The same file converted to doc with forms (password 1234).

When opening this a second bug appears: The forms are black (also in Word 2012).
Comment 13 retired 2014-12-11 10:31:05 UTC
OSX 10.10.1 LO Version: 4.5.0.0.alpha0+
Build ID: 6e91763769a562b88882a4c2a94b1367c6ed4866
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2014-12-11_02:24:05
Locale: de_

persisting. sample file from polach is opened in read-only mode.

Thomas: for the additional issue, please do file a separate bug since one bug per issue.
Comment 14 retired 2014-12-11 10:34:04 UTC
Although, I'm not sure. Had to read through entire bug before finding out PW is "1111". Once I enter the password I'm able to edit the test document.

So I think this is WORKSFORME.

Please re-open if I missed something or the problem is persisting for your with the latest nightly.
Comment 15 Buovjaga 2014-12-11 11:29:24 UTC
It works ok for me, too. Win 7.

Version: 4.5.0.0.alpha0+
Build ID: 6e91763769a562b88882a4c2a94b1367c6ed4866
TinderBox: Win-x86@39, Branch:master, Time: 2014-12-11_00:35:18