Bug Hunting Session
Bug 38152 - Syntax highlighting for Calc
Summary: Syntax highlighting for Calc
Status: RESOLVED DUPLICATE of bug 63859
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-10 06:58 UTC by Marco Zanon
Modified: 2013-10-19 10:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (94.25 KB, image/png)
2013-06-27 13:52 UTC, ign_christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Zanon 2011-06-10 06:58:41 UTC
It would be cool to have Calc to use syntax highlighting on *new* formulas too, not only when *editing* them. Excel does it from 2002.

Thanks, MZ
Comment 1 Don't use this account, use tml@iki.fi 2011-06-10 07:24:02 UTC
Since when does "it would be cool" mean "high priority"?
Comment 2 Marco Zanon 2011-06-10 07:31:03 UTC
I selected "enhancement", because that's not a bug, technically.
However, I choose "high" because I see people very often recognize this as a bug or something like that. So, IMHO, it is kind of a "urgent enhancement".

Please tell me if I made some mistakes when compiling the form.

Thanks, MZ
Comment 3 Björn Michaelsen 2011-12-23 12:20:54 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 ign_christian 2013-06-27 12:30:00 UTC
Hi Marco

I guess what you mean is really like Bug 43089 for Math. Or please give your scenario here if different. Perhaps someone will interest developing that.

Because I can only, unfortunately, using that :)
Comment 5 Marco Zanon 2013-06-27 13:35:53 UTC
Hi Christian,

no, I mean that when you are in Calc and you fill a cell with a formula, cells in that formula are not highlighted (they only are when you *edit* a formula).

This "bug" is also present in 4.0.

Please let me know if you need additional information.

Thanks,
Marco
Comment 6 ign_christian 2013-06-27 13:52:34 UTC
Created attachment 81559 [details]
Screenshot

> no, I mean that when you are in Calc and you fill a cell with a formula,
> cells in that formula are not highlighted (they only are when you *edit* a
> formula).
Ok I guess that cells (within formula) will colored when entering new formula, not only on edit mode. (see screenshot)
 
> This "bug" is also present in 4.0.
We can't say this a bug. But request for enhancement :)
Comment 7 Marco Zanon 2013-06-27 17:20:23 UTC
> Ok I guess that cells (within formula) will colored when entering new
> formula, not only on edit mode. (see screenshot)

exactly

> > This "bug" is also present in 4.0.
> We can't say this a bug. But request for enhancement :)

correct, too :)

thanks,
Marco
Comment 8 ign_christian 2013-10-19 10:11:06 UTC

*** This bug has been marked as a duplicate of bug 63859 ***