Bug Hunting Session
Bug 38222 - LO3.4.0 Incorrectly tracks deletions as deletions of spaces
Summary: LO3.4.0 Incorrectly tracks deletions as deletions of spaces
Status: RESOLVED DUPLICATE of bug 37584
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86-64 (AMD64) Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-12 13:23 UTC by orcmid
Modified: 2013-12-15 22:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Files and Screenshots demonstration reproduction of the bug (234.46 KB, application/zip)
2011-06-12 13:23 UTC, orcmid
Details

Note You need to log in before you can comment on or make changes to this bug.
Description orcmid 2011-06-12 13:23:17 UTC
Created attachment 47877 [details]
Files and Screenshots demonstration reproduction of the bug

I know this bug has been mentioned on LibreOffice lists, but I could not find it on bugs.freedesktop.org.  This may be a duplicate:

When change-tracking applies to simple deletions that where changes are recorded and shown, the deletion will show as a correct strike-out of text and then suddenly change to a strike-out of the same number of spaces.  It is not possible to recover the original text by rejecting the change.

The attached Zip has a .txt file that describes its comments.

The screen captures show a simple deletion immediately after it is made, and then what it became when the Save button was pressed.  The saved file also had the incorrect deletion in the tracked-changes information.

The before and after files are included, and there is an annotated extract of the change-tracking portion of the content.xml file in the package.

This bug seems related to the one reported at 
<https://bugs.freedesktop.org/show_bug.cgi?id=35966>.  In that bug, the deletion is also altered after the fact, but not quite so quickly and not so dramatically.
Comment 1 vitriol 2011-06-12 15:34:06 UTC

*** This bug has been marked as a duplicate of bug 37584 ***