Bug Hunting Session
Bug 38374 - writer: changes made to table are lost
Summary: writer: changes made to table are lost
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: x86-64 (AMD64) Linux (All)
: highest critical
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-16 06:51 UTC by Jiri Kosina
Modified: 2011-10-29 07:38 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
writer_bug.doc (347.50 KB, application/msword)
2011-06-16 06:51 UTC, Jiri Kosina
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kosina 2011-06-16 06:51:38 UTC
Created attachment 48053 [details]
writer_bug.doc

Steps to reproduce: 

1. open the attached document (writer_bug.doc)
2. scroll to page #4
3. There begins a section "5" with several tables in it. The first table already contains some pre-filled data
4. Copy/paste this pre-filled table just after itself
5. [optinal] modify contents of the pre-filled text in the pasted table (in the grey area)
6. Save the file
7. Close Libreoffice
8. Open the saved file
9. Be badly surprised about the contents of the pasted table not being there
Comment 1 Petr Mladek 2011-06-16 08:27:10 UTC
I have reproduced this with LO-3.4.1-rc1.

It might be a problem with .doc export. The problem does not happen when I export it into .odt.

Cedric, Lubos could you please have a look?

It is a data loss => we should fix it for 3.4.2. It would be great to have the fix also in 3.3.4.
Comment 2 Gerald 2011-06-18 11:11:15 UTC
Linux 64bit:
First time I can't change the text because it's a restrictet area (Error message).
Ohter parts of the text I can change.

After save, restart and load:
All changes are in the document
I can change the text in the restrictet area (ops).
Comment 3 Jan Holesovsky 2011-07-01 07:46:11 UTC
Jikosi, jeden pro Tebe ;-)

When you copy/paste a fieldmark, the essential attributes are not preserved; later, when saving, the fieldmark is of unknown type, and ignored.  We should save even the unknown fieldmarks I think, but here I fixed the root cause - that the attributes are not copied.

Sent to ML for review, to get to 3.4.2.