Bug Hunting Session
Bug 38397 - Address book sources for Writer are fewer on MacOSX than other platforms
Summary: Address book sources for Writer are fewer on MacOSX than other platforms
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: bibisected35 bibisected35older
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-17 03:05 UTC by Alex Thurgood
Modified: 2015-01-26 11:16 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2011-06-17 03:05:59 UTC
Thunderbird Address books used to be available in OOo on Mac OSX as a source for defining the AddressBook to be used in Writer.

This functionality is no longer available, and was never released in any of the LibO versions to date.

NeoOffice currently provides access to :

MySQL(ODBC)
MySQL(JDBC)
Oracle JDBC
Spreadsheet
dBase
Text
JDBC
ODBC
Mozilla Address Book
Thunderbird Address Book
LDAP Address Book
Mac OSX Address Book
Mysql(Native)

LibreOffice 3.4 only has :

JDBC
Oracle JDBC
Mac OSX Address Book
Spreadsheet
dBase
Text
MySQL(ODBC)
MySQL(JDBC)
MySQL(Native)
ODBC

Why the difference ? Why shun the availabilities that other platforms have ?
I consider this a regression. If one takes LDAP alone, MacOSX server provides LDAP services out of the box. This now means that LibreOffice does not offer the capability to define an LDAP datasource in Writer for the AddressBook that Mac OS sysadmins will have setup on their networks.

The same applies for Thunderbird/Mozilla address books. Thunderbird must be the most frequently used mail application outside of Mail.app on the Mac platform.


Alex
Comment 1 Caolán McNamara 2011-06-17 04:11:28 UTC
This is inherited, see
http://openoffice.org/bugzilla/show_bug.cgi?id=91209
and search for 91209 in the source. 

This may be out of date now, try re-enabling it in connectivity, and in
scp2, for MacOSX and report back if it works.
Comment 2 Alex Thurgood 2011-06-17 04:59:25 UTC
Excellent, thanks Caolan. Will take a look.

Alex
Comment 3 Björn Michaelsen 2011-12-23 12:25:49 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 sasha.libreoffice 2012-02-16 04:44:47 UTC
@ Alex Thurgood
Still reproducible?
Comment 5 Michael Stahl (CIB) 2012-03-08 12:03:59 UTC
this is actually a Base problem, and would need somebody with a Mac to investigate; the internal Mozilla was updated since this address book support
was disabled, perhaps it would work today?
Comment 6 Alex Thurgood 2012-07-27 06:04:15 UTC
(In reply to comment #5)
> this is actually a Base problem, and would need somebody with a Mac to
> investigate; the internal Mozilla was updated since this address book support
> was disabled, perhaps it would work today?

Hi Michael,

As far as I know, the official builds do not include either LDAP or Mozilla/TB address book support, so perhaps Norbert might like to reconsider providing a build with them in ? However, I will check later on today with a 3.6 RC.


Alex
Comment 7 Alex Thurgood 2012-09-13 15:39:33 UTC
Confirming that there is neither LDAP nor MozTB address book support in the latest Mac OSX daily builds.


Alex
Comment 8 Julien Nabet 2014-06-15 10:35:56 UTC
Ldap is still not present in 4.2.4 but Thunderbird/Icedove is present
Comment 9 Alex Thurgood 2014-09-17 18:08:47 UTC
The only one missing today 17/09/2014 is LDAP.
Comment 10 Julien Nabet 2014-10-11 12:46:16 UTC
Alex: on pc Debian x86-64 with 4.3.2 Debian package, I don't have LDAP now. I don't know if it's normal but, if it is, could we consider this bug as WFM now?
Comment 11 Julien Nabet 2014-10-26 22:08:34 UTC
Stephan: I noticed this commit http://cgit.freedesktop.org/libreoffice/core/commit/?id=0b21dd2593fae41ee430717d7d65e2cfca25b8e9, can/should we enable LDAP on MacOs?
Comment 12 Alex Thurgood 2015-01-03 17:39:59 UTC
Adding self to CC if not already on
Comment 13 Matthew Francis 2015-01-14 14:40:45 UTC
As also mentioned in comment 1, this was already the case in 3.3.0, hence not a regression with respect to LibreOffice

-> Version: Inherited from OOo
-> Removed Keywords: regression and Whiteboard: bibisected35 bibisected35older
Comment 14 Alex Thurgood 2015-01-26 11:16:23 UTC
Ok, so let's close this as wfm