Bug 38401 - [wish list] Word Document Tabs (Divisions)
Summary: [wish list] Word Document Tabs (Divisions)
Status: RESOLVED DUPLICATE of bug 37134
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-17 05:04 UTC by John B
Modified: 2019-03-12 16:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John B 2011-06-17 05:04:31 UTC
There must be 10's of thousands of Lotus Smart Suite users who use Lotus Wordpro who cannot move (locked in) to any other software because of a brilliant internal tab filing structure within wordpro. This is where you can put standard tabs inside Group tabs.

Because Libreoffice thankfully support Lotus Smart Suite documents (and IBM no longer do), you would be the natural inheritor for all these folk. 

At the moment I am not aware of any other software that even have tab documents within a Word processor so you would be unique.

One tab can be for any amount of pages (also called a division).

The beauty of tab documents is that in one file you can have all the documents for say one client, one book etc. laid out in say years +2011, +2011 ..... +1995 or chapters etc. and inside (by clicking the +) the group tab opens up and you can have inside other tabs for all that years correspondence or headings or whatever etc).

Now by having them all in one file, then a document produced in say 2000 is not archived or deleted as every time a new document is added the whole file is updated to the current date, so backing up by current date massively improves.
I have files on current clients that go back to 1991, the "+" means that it is a "group tab" and that there are other tabs inside (and maybe more inside them) etc., Hence its an effective filing structure to handle multi documents.

I have group tabs that go like this "+1990's" > "+1991" > "Contracts" > (then a single tab "12/03/91"

Hence, you can also go straight to a division, click on it and Print it as a separate item. You can copy & paste, insert, you can move a tab, (like making it the 1st or last page(s) in a document.

The problem now is that if a Wordpro document, fully tabbed with say 10 - 1000 Tabs and by transferring it to LibreOfice it just becomes an unmanageable 10 to say 10,000 pages, with no structure.

Managing large documents or many documents over a long period of time becomes achievable with Tabs (divisions)

I would have thought that this would be useful in any word processor. Please consider this.

Thank you

John Brassington
johnb@email2.me
Comment 1 Michael Meeks 2011-06-20 07:36:10 UTC
IMHO implementing the tab feature would take quite some work here, instead it might be good to insert a set of links in the document at the top to allow quick jumping to the various sections;

But of course, this is all work. Lets see if some volunteer jumps in to do it - otherwise if you pay someone to do the work, you can have it done as you like I guess.
Comment 2 Björn Michaelsen 2011-12-23 12:28:04 UTC Comment hidden (spam)
Comment 3 Roman Eisele 2012-05-03 05:22:15 UTC
Well, this feature (enhancement) request is still valid, therefore let's set Status to New again. The Component should be Writer, according to the original description and Summary. And the Platform should be All, of course, or do you request this stuff for Windows only? ;-)
Comment 4 Adolfo Jayme 2017-10-15 10:29:16 UTC

*** This bug has been marked as a duplicate of bug 33173 ***
Comment 5 V Stuart Foote 2019-03-12 16:48:32 UTC
QA housekeeping adjusting the duplicate to bug 37134 from bug 33173

*** This bug has been marked as a duplicate of bug 37134 ***