Download it now!
Bug 38411 - FILEOPEN FORMATTING images displayed wrong in DOC
Summary: FILEOPEN FORMATTING images displayed wrong in DOC
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: Other All
: medium normal
Assignee: Luboš Luňák
URL:
Whiteboard: target:4.3.0 target:4.2.4
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-17 07:53 UTC by Andras Timar
Modified: 2014-04-14 07:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
sample DOC with images (245.00 KB, application/msword)
2011-06-17 07:53 UTC, Andras Timar
Details
the same document, saved as PDF using msWord 2007 (232.39 KB, application/pdf)
2012-09-18 09:49 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2011-06-17 07:53:50 UTC
Created attachment 48104 [details]
sample DOC with images

The attached DOC contains small cards with pictures. In LibreOffice some of the pictures are totally messed up. Instead of one card - one picture, some cards contain many pictures in miniaturised form. See the attachment.
Comment 1 Björn Michaelsen 2011-12-23 12:23:27 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Florian Reisinger 2012-08-14 13:59:13 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 3 Florian Reisinger 2012-08-14 14:00:26 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:05:07 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:07:10 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 sasha.libreoffice 2012-09-18 09:49:22 UTC
Created attachment 67318 [details]
the same document, saved as PDF using msWord 2007
Comment 7 sasha.libreoffice 2012-09-18 10:02:11 UTC
Problems reproduced in 3.3.4 and 3.6.1 on Fedora 64 bit
1. Pictures cropping is lost. All pictures become not cropped.
2. Font property is lost. Something like "Make all caps" 

(msWord complains about corrupted document, but tells that all problems solved successfully)
Comment 8 Commit Notification 2014-04-13 21:10:14 UTC
LuboÅ¡ LuÅak committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=af51f3fb5aee469423b154958ccb3fe61284122f

handle .doc cropping also inside groups (fdo#38411)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2014-04-14 07:06:59 UTC
LuboÅ¡ LuÅak committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2612f51f9373d869f714ae1269143a5c09f4608e&h=libreoffice-4-2

handle .doc cropping also inside groups (fdo#38411)


It will be available in LibreOffice 4.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.