Bug 38617 - Wish: Import multiple images in a row (one per page or auto placement)
Summary: Wish: Import multiple images in a row (one per page or auto placement)
Status: RESOLVED DUPLICATE of bug 35546
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-23 13:18 UTC by ralf
Modified: 2013-04-27 22:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ralf 2011-06-23 13:18:11 UTC
Hello,

I am very content with LibreOfficeDraw, and I use it
increasingly to build PDF files from a set of 
(scanned) bitmap images.

The workflow could be improved (especially if you
want to create more than 1 page), and I think
the work to implement this enhancement is less
than the value of this huge improvement.

A. Approach for Insert:Image:from file
1. Allow selection of multiple files when
importing images from file, please.

2. First approach could be to create one 
page for each image opened, later some
intelligent placement could be interesting, 
just to place all pictures to save the
amount of pages to print.

B. Drag and Drop
Another workflow is to drag and drop the images
onto the LO Draw window.

1. In this case, I wish being able adding more
than one page at once (right click on page,
new pages..., enter amount).

2. Once I created a set of (blank) pages, I'd
wish I could also drop the images on the
page previews (left frame) rather than
having to activate the corresponding page
before being able to drop it onto the page
itself (right frame).

C. All these features might get less desirable
as soon we have an intelligent multiple import
operation - maybe as an extension?
Comment 1 Björn Michaelsen 2011-12-23 12:25:17 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Florian Reisinger 2012-08-14 14:00:49 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 3 Florian Reisinger 2012-08-14 14:01:56 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:06:38 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:08:40 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 sasha.libreoffice 2012-09-20 12:31:20 UTC
reopening because it is RFE.
Sometimes this feature can very seriously increase productivity of user.
IMHO this feature may be written using Basic Macro. May be even it already exists somewhere among extensions.
Comment 7 Samuel Mehrbrodt (CIB) 2013-04-27 22:27:34 UTC
Hi, please check Bug 35546. It is already partly implemented.
I hope that is what you wanted?

*** This bug has been marked as a duplicate of bug 35546 ***