Bug Hunting Session
Bug 38623 - CRASH, FILEOPEN - opening MS word processor document causes crash
Summary: CRASH, FILEOPEN - opening MS word processor document causes crash
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86 (IA32) Mac OS X (All)
: high critical
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords: regression
: 39084 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-23 16:16 UTC by Martin Trautmann
Modified: 2011-10-29 07:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
crash trace for MS doc import bug (51.94 KB, text/plain)
2011-06-24 02:24 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Trautmann 2011-06-23 16:16:24 UTC
while trying to open
<http://www.europarl.europa.eu/sides/getDoc.do?pubRef=-//EP//NONSGML+TA+20110623+SIT-03+DOC+WORD+V0//DE&language=DE>

the application crashed.

Ending .do was changed to .doc first.

Mac TextWriter could oben the .doc without major trouble.
Comment 1 fabien.michel 2011-06-24 01:51:41 UTC
Reproduced on :
LibreOffice 3.4.1 OOO340m1 (Build:101)
MacOS X Leopard (10.5)
Intel Core 2 Duo

But not with OOoLight OOL102r1100 (Build:10)
on the same platform
It open the file successfully.
Comment 2 Alex Thurgood 2011-06-24 02:23:14 UTC
Hi,

I can not reproduce here when I pass the download straight to LibreOffice 3.3.2, it opens fine on MacOSX. You don't have to change the name of the file extension, LibreOffice can open up the file without that.

However, I can reproduce when I try to open it in 3.4 m1 build 12.
Attaching apple crash trace.

Setting regression with regard to 3.3.2. 

Additionally, this might actually be a duplicate of other doc/docx crash causing bugs already registered.


Alex
Comment 3 Alex Thurgood 2011-06-24 02:24:55 UTC
Created attachment 48372 [details]
crash trace for MS doc import bug
Comment 4 Alex Thurgood 2011-06-24 02:50:39 UTC
Still crashes with 3.4.1rc1.

Alex
Comment 5 Alex Thurgood 2011-06-24 02:51:11 UTC
defined title of report more precisely
Comment 6 Alex Thurgood 2011-06-24 02:59:31 UTC
Not that it makes much difference (because its a crasher anyway), but setting importance to high.

Alex
Comment 7 Caolán McNamara 2011-06-24 05:02:40 UTC
I can reproduce this, easy enough workaround I guess.
Comment 9 Jan Holesovsky 2011-06-24 07:02:20 UTC
Caolan: Thanks for that!  Signed-off & cherry-picked to libreoffice-3-4, so it will be in 3.4.2.
Comment 10 Martin Trautmann 2011-06-24 07:06:09 UTC
Thanks from  me, too - that was fast.
Comment 11 Petr Mladek 2011-06-27 02:42:42 UTC
Just for record. The bug will be fixed in 3.4.2 release. It affects only limited number of documents => we do not want to block the 3.4.1 release because of this.

In the meantime, you could use the nightly builds, see http://dev-builds.libreoffice.org/daily/
Comment 12 Caolán McNamara 2011-07-09 08:31:11 UTC
*** Bug 39084 has been marked as a duplicate of this bug. ***