Bug Hunting Session
Bug 38637 - [Task] Better handling for csv-Files
Summary: [Task] Better handling for csv-Files
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 RC2
Hardware: All All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 35019 32703 36674 38088
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-24 04:56 UTC by Alexander Balzer
Modified: 2018-10-27 22:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Balzer 2011-06-24 04:56:24 UTC
Especially in business it is sometimes required to automate some processes.
The current implementation of csv import does not alow this.


1. the delimiter of the csv file should be auto-detected, so no dialog is needed
2. char set auto-detection
3. provide commandline options in case 1 - 2 fail


related bugs are:
32703
35019 - charset autodetection
38088 - Import csv defaults 
36674 - Importing tab separated file (maybe)
Comment 1 Björn Michaelsen 2011-12-23 12:24:48 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Florian Reisinger 2012-08-14 14:00:24 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 3 Florian Reisinger 2012-08-14 14:01:32 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:06:15 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:08:16 UTC Comment hidden (obsolete)