Download it now!
Bug 38643 - UI:AutoInput stops proposing after 1 letter if input starts with "+" or "-"
Summary: UI:AutoInput stops proposing after 1 letter if input starts with "+" or "-"
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.1 RC1
Hardware: x86 (IA32) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-24 07:15 UTC by pierre-yves samyn
Modified: 2017-10-26 16:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2011-06-24 07:15:34 UTC
Hello

Build Date & Platform: XP & LibO 3.4.1RC1 buildid=340m1(Build:101)

Steps to Reproduce:

First of all what works...

1. Open new Spreadsheet
2. Type azer into A1
3. Type qwer into A2
3. Click on A3
4. Type q

Expected Results: wer (completion text) is highlighted.
Actual Results: OK

5. Type w

Expected Results: er (completion text) is highlighted.
Actual Results: OK

This does not work:

6. Type +azer into B1
7. Type +qwer into B2
8. Click on B3
9. Type +

Expected Results: azer (completion text) is highlighted.
Actual Results: OK

10. Type q

Expected Results: wer (completion text) is highlighted.
Actual Results: nor more completion

Additional Information: 
- Same problem if the cells are formatted as text
- Same problem with older versions (OOo 2.4.2, 3.2.1...)
- Reproduced on fr-discuss


Best regards
Pierre-Yves
Comment 1 Björn Michaelsen 2011-12-23 12:27:06 UTC Comment hidden (obsolete)
Comment 2 pierre-yves samyn 2011-12-24 03:01:06 UTC
Hello

Still persists with LOdev 3.5.0beta2+ Build ID: 62b9587-7ef74e0-7bf1c81

Regards
PYS
Comment 3 pierre-yves samyn 2012-07-01 04:32:02 UTC
Still persists with Version 3.6.0.0.beta2 (Build ID: f010139)
Comment 4 Rainer Bielefeld Retired 2012-09-05 05:44:44 UTC
[Reproducible] with Server Installation of  "LibreOffice  3.6.2.0+  English UI/ German Locale [Build-ID:  6781ee7] on German WIN7 Home Premium (64bit)  {tinderbox: Win-x86@9, pull time2012-08-31 19:54:09}

I additionally checked with leading character /, *, §, $, %, ), #
Always worked fine, only with leading + or - typing the second character of a words ends AutoInput suggestion.
Comment 5 QA Administrators 2015-10-14 19:57:42 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2016-01-30 13:38:04 UTC
Yeah, it starts to offer QUARTILE()

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 9784ff3d878eaa21491fbd779e57d7d4710f5449
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-30_01:31:57
Locale: fi-FI (fi_FI)
Comment 7 pierre-yves samyn 2016-04-22 09:25:30 UTC
Hi

Still reproduced on windows 7/64 & Version: 5.2.0.0.alpha1 (x64)
Build ID: 902b28a39528b6c92602e9b521a1d0861be1caf9
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR)

Regards
Pierre-Yves
Comment 8 QA Administrators 2017-10-23 14:11:15 UTC Comment hidden (obsolete)
Comment 9 pierre-yves samyn 2017-10-23 16:49:19 UTC
Hi

Still reproduced on windows 7/67 & Version: 5.4.2.2
Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: fr-FR (fr_FR); Calc: group

However, as indicated in comment 6, Calc completes the input by a function name.
This is normal since formula input beginning with + is accepted.

So I'm not sure, after thinking, that it's a bug?

Best regards
Pierre-Yves
Comment 10 Buovjaga 2017-10-26 16:52:56 UTC
(In reply to pierre-yves samyn from comment #9)
> However, as indicated in comment 6, Calc completes the input by a function
> name.
> This is normal since formula input beginning with + is accepted.
> 
> So I'm not sure, after thinking, that it's a bug?

I asked Eike for a comment:
yeah, the dreaded + and - start a formula feature..
invented for data typists who type only on numeric keyboards, which nowadays ~noone has anymore
or German keyboards where one has to press Shift as well what a dreaded key combination..

So I guess we should close..