Download it now!
Bug 38691 - [UI] shortcut in menu for "Delete Contents" is incorrect
Summary: [UI] shortcut in menu for "Delete Contents" is incorrect
Status: RESOLVED DUPLICATE of bug 33149
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 31652
  Show dependency treegraph
 
Reported: 2011-06-26 04:23 UTC by Korrawit Pruegsanusak
Modified: 2011-06-26 07:01 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Korrawit Pruegsanusak 2011-06-26 04:23:16 UTC
In a nutshell
- currently LibO use "Delete" for delete without asking, and BackSpace with an ask ("Delete Contents").
- There's a compatibility feature to use swapped key (which is in OO.o)
- Since Bug 31652, the shortcut text is still incorrect

Step to reproduce:
- Open calc
- Make sure you have set key bindings default: Tools > Options > Libreoffice Calc > Compatibility > Default > OK
- click Edit menu, see "Delete Contents", its shortcut still "Delete", incorrect!
- click it, there is a dialog asking
- you may test with typing "Delete", no dialog, but typing "BackSpace", there's a dialog
- So, this should change text in menu to "BackSpace"

- Change to compatibility mode: Tools > Options > Libreoffice Calc > Compatibility > OpenOffice.org legacy > OK
- test again with deleting, now "Delete" produces a dialog, "BackSpace" doesn't.
- Shortcut text hasn't changed yet, so it is now correct.

The point from Cor Nouws is, is it possible to change text string after LibO start? It should change according to each mode.

Tested on LibreOffice 3.3.3 OOO330m19 (Build:301) tag libreoffice-3.3.3.1 Windows XP

Thanks Cor Nouws for rising this issue.
Comment 1 Markus Mohrhard 2011-06-26 04:58:31 UTC
this should already be fixed in libreoffice 3.4

There was a general problem around with updating the shown shortcuts.

http://cgit.freedesktop.org/libreoffice/libs-core/commit/?id=e1050cc8589df4dd685d0fae2079dd306d1f09ff
Comment 2 Korrawit Pruegsanusak 2011-06-26 07:01:21 UTC
Thanks Markus.

*** This bug has been marked as a duplicate of bug 33149 ***