Download it now!
Bug 38782 - Crash on pasting html
Summary: Crash on pasting html
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-29 11:21 UTC by Divakar Ramachandran
Modified: 2012-08-31 10:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Divakar Ramachandran 2011-06-29 11:21:31 UTC
Pasting a specific part of html (copied from Firefox - listing of publications from researcherid.com) causes Writer to crash. LO offers to recover doc on restart nut the recovered doc does not contain pasted offending part. After a number of tries, I have isolated the offending code as the following:

--begin--
<input name="artifacts[0].doi" value="10.1021/nl070430o" type="hidden"> <img src="http://images.isiknowledge.com/RIDR42010/images/RID/view_full_text.gif" style="cursor: pointer;" onclick='javascript:window.open("http://dx.doi.org/10.1021/nl070430o")'>
--end--

On the webpage this is a small img linked to full text of journal paper.

Happens consistently on LibreOffice 3.4.0 OOO340m1 (Build:12) (irrespective of prior contents of document) running on Microsoft Windows 7 Professional 64-bit on a Dell Inspiron 580 with 4GB RAM.
Comment 1 Divakar Ramachandran 2011-07-01 23:42:29 UTC
(In reply to comment #0)

Confirmed that this happens to web linked gif pasted from Firefox browser on LO3.4 running on Ubuntu 10.04 LTS 64-bit also
Comment 2 tester8 2011-07-03 09:16:38 UTC
NOT reproduced with

LO 3.4.1 (OOO340m1 (Build:101))
Ubuntu 10.04.2 x86
Linux 2.6.32-32-generic Russian UI

Firefox 5.0  &  Chromium 12.0
Comment 3 Björn Michaelsen 2011-12-23 12:21:22 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 sasha.libreoffice 2012-03-01 02:33:44 UTC
@ Divakar
Please, verify: in last version of Libre Office still reproducible?
Comment 5 Florian Reisinger 2012-08-14 13:57:56 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 13:59:15 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 14:03:49 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 8 Florian Reisinger 2012-08-14 14:06:03 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian