Bug 38791 - FILEOPEN - ReportBuilder: existing report with .JPG
Summary: FILEOPEN - ReportBuilder: existing report with .JPG
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Stephan Bergmann
URL:
Whiteboard: target:3.7.0 target:3.6.2
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-29 22:42 UTC by Alex Thurgood
Modified: 2012-08-30 03:35 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of java error (229.20 KB, image/png)
2011-06-29 22:42 UTC, Alex Thurgood
Details
test db document including image inserted in report (34.66 KB, application/vnd.sun.xml.base)
2012-08-14 09:41 UTC, Alex Thurgood
Details
Screenshot: My results for bug 38791 (LibO 3.6.1.1 on MacOS X 10.6.8) (170.41 KB, image/png)
2012-08-17 15:18 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2011-06-29 22:42:13 UTC
Created attachment 48576 [details]
screenshot of java error

Version :

Nightly build from 20110628 - LibO-dev 3.5.0 OOO350m1 (Build:0)


How to reproduce :
1) Create a report with the Oracle Report Builder extension.
2) Open the report in Design mode.
3) Insert an image container into the report. 
4) Right-mouse button click and select to display its properties, then insert a JPEG image.
5) Save the report and close the designer.
6) Now try and open the report for viewing (not design mode).

What you get :
An window full of Java error messages. The report does not open.

What you should get :
A report displaying the image just inserted.


If you go back into Design mode and delete the image container, resave the document, and then try to reopen it, everything works fine again.


Enclosing screenshot of Java error message.

Alex
Comment 1 Rainer Bielefeld Retired 2011-09-12 22:06:13 UTC
Modified Version due to report.
Comment 2 Björn Michaelsen 2011-12-23 12:23:02 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Robert Großkopf 2012-08-14 06:41:03 UTC
Does this problem already exist with 3.5.5?
I could not test it, because I haven't Mac. Somebody had changed the Version to "Master old-3.6". Has anybody tested it with this version?
Comment 4 Rainer Bielefeld Retired 2012-08-14 07:35:28 UTC
NOT reproducible with Server Installation of  "LibreOffice 3.6.1.0+  English UI/ German Locale [Build-ID:  b0aac2a] on German WIN7 Home Premium (64bit)  {tinderbox: Win-x86@9, pull time 2012-08-11 00:16:39}

My steps:
0. Download Attachment 56260 [details] of "Bug 45338 - EDITING ReportBuilder: 
  'Details - General Keep Together' without visible effect"
1. Download Attachment 55911 [details] (test picture)
2. Launch LibO, open DB from LibO Start Center File dialog
3. Open existing Report in Edit mode
4. Click into empty white heading contents area
5. Menu 'Insert -> Picture from file - select downloaded picture -> <open>
   Picture appears
6. Menu 'File -> Save'
7. close Report Designer
8. Double click report to open report result view
   Expected: Writer document with report and picture in heading
   Actual: as expected.

Also NOT reproducible with LibO 3.5.6.2, LibO 3.4.1.1

So might be Mac related?

@Robert:
The Version question is rather academic as long as nobody has reproduced the problem. Concerning Version please see original report!

@Roman:
It would be great if you could try if Alex confirms that it is still a problem for him.

@Alex:
Needinfo because your report is pretty old. Still a problem repeating my test?
Comment 5 Alex Thurgood 2012-08-14 09:04:36 UTC
(In reply to comment #4)


> @Alex:
> Needinfo because your report is pretty old. Still a problem repeating my test?


Oooh, yes, this one slipped off my radar. I'll retest and report back, closing if it now works OK for me.


Alex
Comment 6 Alex Thurgood 2012-08-14 09:15:49 UTC
The problem is still present in LibreOffice 3.5.5.3 
Version ID : 7122e39-92ed229-498d286-15e43b4-d70da21


Alex
Comment 7 Alex Thurgood 2012-08-14 09:17:24 UTC
Am trying to get a trace file somewhere with the Java errors, because the Java error window itself is bigger than the actual screen on my Macbook.


Alex
Comment 8 Alex Thurgood 2012-08-14 09:38:17 UTC
Reproducible also on Version 3.7.0.0.alpha0+ (Build ID: fdfb7a3)
Comment 9 Alex Thurgood 2012-08-14 09:40:12 UTC
My original report was filed when I was using Mac OSX 10.6 (Snow Leopard), and I am now on Mac OSX 10.8 (Mountain Lion), so it doesn't appear to be OS version related.


Alex
Comment 10 Alex Thurgood 2012-08-14 09:41:27 UTC
Created attachment 65538 [details]
test db document including image inserted in report
Comment 11 Alex Thurgood 2012-08-14 09:50:16 UTC
@Thorsten : your call, I think ?


Alex
Comment 12 Alex Thurgood 2012-08-14 09:51:05 UTC
Sorry Thorsten, wrong bug, please ignore.

Alex
Comment 13 Robert Großkopf 2012-08-14 10:19:42 UTC
@Alex
Testdocument won't work, because pictures could not be included in the *.odb-file. I solve this problem by putting pictures into a separate table.

The problem seems to be a Mac-problem - not specific to the OS of Mac. I worked with pictures in report since OOo 3.1.1 and never had a problem with openening a report with pictures (png, jpg). It works also in LO 3.3.4 and LO 3.6 under OpenSuSE 32bit rpm.
Comment 14 Alex Thurgood 2012-08-14 11:50:50 UTC
So, I started LOdev from the command line, and this is what I see when I try to
open up (double-click) the Report attached in the ODB file of this issue :


Aug 14, 2012 1:44:25 PM org.pentaho.reporting.libraries.base.boot.AbstractBoot
start
INFO: LibSerializer 1.1.6.10682 started.
Aug 14, 2012 1:44:25 PM org.pentaho.reporting.libraries.base.boot.AbstractBoot
start
INFO: LibBase 1.1.6.10682 started.
Aug 14, 2012 1:44:25 PM org.pentaho.reporting.libraries.base.boot.AbstractBoot
start
INFO: LibLoader 1.1.6.10682 started.
Aug 14, 2012 1:44:25 PM org.pentaho.reporting.libraries.base.boot.AbstractBoot
start
INFO: LibRepository 1.1.6.10682 started.
Aug 14, 2012 1:44:25 PM org.pentaho.reporting.libraries.base.boot.AbstractBoot
start
INFO: LibFonts 1.1.6.10682 started.
Aug 14, 2012 1:44:25 PM org.pentaho.reporting.libraries.base.boot.AbstractBoot
start
INFO: LibLayout null started.
Aug 14, 2012 1:44:25 PM org.pentaho.reporting.libraries.base.boot.AbstractBoot
start
INFO: LibFormula 1.1.7.10682 started.
Aug 14, 2012 1:44:25 PM org.pentaho.reporting.libraries.base.boot.AbstractBoot
start
INFO: LibXML 1.1.7.10682 started.
Aug 14, 2012 1:44:25 PM
org.pentaho.reporting.libraries.base.boot.PackageManager loadModule
WARNING: Exception while loading module:
org.pentaho.reporting.libraries.base.boot.DefaultModuleInfo={ModuleClass=org.jfree.report.modules.gui.swing.common.SwingCommonModule}
java.lang.NullPointerException
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.containsModule(PackageManager.java:369)
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.loadModule(PackageManager.java:436)
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.addModule(PackageManager.java:330)
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.load(PackageManager.java:199)
    at org.jfree.report.JFreeReportBoot.performBoot(Unknown Source)
    at
org.pentaho.reporting.libraries.base.boot.AbstractBoot.start(AbstractBoot.java:197)
    at
com.sun.star.report.pentaho.PentahoReportEngine.<init>(PentahoReportEngine.java:36)
    at
com.sun.star.report.pentaho.SOReportJobFactory$_SOReportJobFactory.createReportJob(SOReportJobFactory.java:319)
    at
com.sun.star.report.pentaho.SOReportJobFactory$_SOReportJobFactory.execute(SOReportJobFactory.java:213)
Aug 14, 2012 1:44:25 PM
org.pentaho.reporting.libraries.base.boot.PackageManager loadModule
WARNING: Exception while loading module:
org.pentaho.reporting.libraries.base.boot.DefaultModuleInfo={ModuleClass=org.jfree.report.modules.gui.swing.html.SwingHtmlModule}
java.lang.NullPointerException
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.containsModule(PackageManager.java:369)
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.loadModule(PackageManager.java:436)
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.addModule(PackageManager.java:330)
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.load(PackageManager.java:199)
    at org.jfree.report.JFreeReportBoot.performBoot(Unknown Source)
    at
org.pentaho.reporting.libraries.base.boot.AbstractBoot.start(AbstractBoot.java:197)
    at
com.sun.star.report.pentaho.PentahoReportEngine.<init>(PentahoReportEngine.java:36)
    at
com.sun.star.report.pentaho.SOReportJobFactory$_SOReportJobFactory.createReportJob(SOReportJobFactory.java:319)
    at
com.sun.star.report.pentaho.SOReportJobFactory$_SOReportJobFactory.execute(SOReportJobFactory.java:213)
Aug 14, 2012 1:44:25 PM
org.pentaho.reporting.libraries.base.boot.PackageManager loadModule
WARNING: Exception while loading module:
org.pentaho.reporting.libraries.base.boot.DefaultModuleInfo={ModuleClass=org.jfree.report.modules.gui.swing.pdf.SwingPdfModule}
java.lang.NullPointerException
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.containsModule(PackageManager.java:369)
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.loadModule(PackageManager.java:436)
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.addModule(PackageManager.java:330)
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.load(PackageManager.java:199)
    at org.jfree.report.JFreeReportBoot.performBoot(Unknown Source)
    at
org.pentaho.reporting.libraries.base.boot.AbstractBoot.start(AbstractBoot.java:197)
    at
com.sun.star.report.pentaho.PentahoReportEngine.<init>(PentahoReportEngine.java:36)
    at
com.sun.star.report.pentaho.SOReportJobFactory$_SOReportJobFactory.createReportJob(SOReportJobFactory.java:319)
    at
com.sun.star.report.pentaho.SOReportJobFactory$_SOReportJobFactory.execute(SOReportJobFactory.java:213)
Aug 14, 2012 1:44:25 PM
org.pentaho.reporting.libraries.base.boot.PackageManager loadModule
WARNING: Exception while loading module:
org.pentaho.reporting.libraries.base.boot.DefaultModuleInfo={ModuleClass=org.jfree.report.modules.gui.swing.preview.SwingPreviewModule}
java.lang.NullPointerException
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.containsModule(PackageManager.java:369)
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.loadModule(PackageManager.java:436)
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.addModule(PackageManager.java:330)
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.load(PackageManager.java:199)
    at org.jfree.report.JFreeReportBoot.performBoot(Unknown Source)
    at
org.pentaho.reporting.libraries.base.boot.AbstractBoot.start(AbstractBoot.java:197)
    at
com.sun.star.report.pentaho.PentahoReportEngine.<init>(PentahoReportEngine.java:36)
    at
com.sun.star.report.pentaho.SOReportJobFactory$_SOReportJobFactory.createReportJob(SOReportJobFactory.java:319)
    at
com.sun.star.report.pentaho.SOReportJobFactory$_SOReportJobFactory.execute(SOReportJobFactory.java:213)
Aug 14, 2012 1:44:25 PM
org.pentaho.reporting.libraries.base.boot.PackageManager loadModule
WARNING: Exception while loading module:
org.pentaho.reporting.libraries.base.boot.DefaultModuleInfo={ModuleClass=org.jfree.report.modules.gui.swing.printing.SwingPrintingModule}
java.lang.NullPointerException
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.containsModule(PackageManager.java:369)
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.loadModule(PackageManager.java:436)
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.addModule(PackageManager.java:330)
    at
org.pentaho.reporting.libraries.base.boot.PackageManager.load(PackageManager.java:199)
    at org.jfree.report.JFreeReportBoot.performBoot(Unknown Source)
    at
org.pentaho.reporting.libraries.base.boot.AbstractBoot.start(AbstractBoot.java:197)
    at
com.sun.star.report.pentaho.PentahoReportEngine.<init>(PentahoReportEngine.java:36)
    at
com.sun.star.report.pentaho.SOReportJobFactory$_SOReportJobFactory.createReportJob(SOReportJobFactory.java:319)
    at
com.sun.star.report.pentaho.SOReportJobFactory$_SOReportJobFactory.execute(SOReportJobFactory.java:213)
Aug 14, 2012 1:44:26 PM org.pentaho.reporting.libraries.base.boot.AbstractBoot
start
INFO: Pentaho Reporting Flow-Engine null started.
2012-08-14 13:44:28.271 soffice[11855:707] Apple AWT Java VM was loaded on
first thread -- can't start AWT.
Comment 15 Alex Thurgood 2012-08-14 11:54:30 UTC
(In reply to comment #13)
> @Alex
> Testdocument won't work, because pictures could not be included in the
> *.odb-file. I solve this problem by putting pictures into a separate table.
> 
> The problem seems to be a Mac-problem - not specific to the OS of Mac. I worked
> with pictures in report since OOo 3.1.1 and never had a problem with openening
> a report with pictures (png, jpg). It works also in LO 3.3.4 and LO 3.6 under
> OpenSuSE 32bit rpm.

Hi Robert,

Yes, it would indeed appear that this is a Mac only problem, seemingly stemming from wrong Java thread initialisation by the Pentaho reporter engine on Mac (at least, for the function required).

Alex
Comment 16 Alex Thurgood 2012-08-14 12:00:11 UTC
@Lionel : assigning to you, the AWT thread attachment issue is an old one that periodically raises its head from time to time on Mac.


Alex
Comment 17 Alex Thurgood 2012-08-14 12:01:16 UTC
(In reply to comment #16)
> @Lionel : assigning to you, the AWT thread attachment issue is an old one that
> periodically raises its head from time to time on Mac.
> 
> 
> Alex

@Lionel : if the test document I've posted here doesn't work for you, I can send you a copy via e-mail.


Alex
Comment 18 Alex Thurgood 2012-08-14 12:05:50 UTC
I am resetting this back to 3.5.5.3, which is currently the earliest version I can confirm where the problem is present. I have no idea what master3.6-old is supposed to mean, and I don't recall setting it to that version.


Alex
Comment 19 Rainer Bielefeld Retired 2012-08-14 12:53:18 UTC
I updated Version info on <https://wiki.documentfoundation.org/BugReport_Details#Version_Picker:_Particular_Versions>
Comment 20 Lionel Elie Mamane 2012-08-14 13:46:14 UTC
Well, a Mac-only version will be quite hard for me to work on (I don't have access to a Mac). It is probably best if somebody else takes care of it. I'm available for any question / support needed.
Comment 21 Alex Thurgood 2012-08-15 07:06:35 UTC
Hi Thorsten,

Assigning to you since Lionel doesn't have a Mac to try and sort this out. Please feel free to reassign as appropriate.

Alex
Comment 22 Alex Thurgood 2012-08-15 07:07:38 UTC
(In reply to comment #19)
> I updated Version info on
> <https://wiki.documentfoundation.org/BugReport_Details#Version_Picker:_Particular_Versions>

Thanks Rainer !!
All the best,

Alex
Comment 23 Roman Eisele 2012-08-17 15:18:54 UTC
Created attachment 65701 [details]
Screenshot: My results for bug 38791 (LibO 3.6.1.1 on MacOS X 10.6.8)



(In reply to comment #4)
> @Roman:
> It would be great if you could try if Alex confirms that it is still a problem
> for him.

@Rainer:
Sorry that I did not answer to your question earlier -- I was not often at my computer in the last two weeks (holiday), and I am not into Base ;-)

But now I have tried to reproduce this issue following Rainer’s steps given in comment #4, and the issue is REPRODUCIBLE for me with LibreOffice 3.6.1.1 (Build ID: 4db6344), German langpack installed, on MacOS X 10.6.8 (Intel).

After Rainer’s step 8:
> 8. Double click report to open report result view
>    Expected: Writer document with report and picture in heading
I get the same result as Alex (comment #0):
>    A window full of Java error messages. The report does not open.

A screenshot of the error box is attached to this comment. And, yes, Java is installed and works fine on my machine (JRE used, if this of some importance: Apple’s own JRE, version 1.6.0_33, i.e. the current version for MacOS X 10.6.x).
Comment 24 Jochen 2012-08-17 15:36:38 UTC
Hi Thorsten,

can I change status from "NEW" to "ASSIGNED"?
Comment 25 Lionel Elie Mamane 2012-08-22 06:22:15 UTC
The interesting tidbit seems to be:

 2012-08-14 13:44:28.271 soffice[11855:707] Apple AWT Java VM was loaded on first thread -- can't start AWT.

and the exception shown in the screenshots points in the same direction: could not load class java.awt.Dimension.

My guess is that either:

 1) AWT can only be loaded on one thread on all platforms.
    LibreOffice loads AWT on "first thread" only on Mac,
    for some reason to find out.

OR

 2) AWT can be loaded in multiple threads on most platforms,
    but not on Mac.

@sbergman: It seems that in https://issues.apache.org/ooo/show_bug.cgi?id=92926, you solved something similar (same error message). Could you take a look here?
Comment 26 Not Assigned 2012-08-23 12:37:49 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=86a60b36552d5785a33bc9eed1e082bd5c54100f

fdo#38791: Do not use java.awt, causes problems on Mac OS X
Comment 27 Not Assigned 2012-08-30 03:35:55 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3f8da6ae8b6584cf6a95fc9b1f4f9045270c0555&g=libreoffice-3-6

fdo#38791: Do not use java.awt, causes problems on Mac OS X


It will be available in LibreOffice 3.6.2.