Download it now!
Bug 38802 - function changes itself
Summary: function changes itself
Status: RESOLVED DUPLICATE of bug 38204
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86-64 (AMD64) Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard: target:3.4.2
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-30 05:30 UTC by Erkki
Modified: 2011-12-23 14:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
xls spreadsheet (97.50 KB, application/vnd.ms-excel)
2011-06-30 05:30 UTC, Erkki
Details
problem cut down xls (7.00 KB, application/vnd.ms-excel)
2011-07-01 04:20 UTC, ndd.filter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erkki 2011-06-30 05:30:11 UTC
Created attachment 48592 [details]
xls spreadsheet

I write a function in a cell 
Save and close.
When opened again the function has changed itself. Something  has dropped out, something is more.
Comment 1 Erkki 2011-06-30 05:48:46 UTC
The changes happen by opening. If I open the saved xls with Microsoft Excel, it is OK.
Comment 2 Markus Mohrhard 2011-06-30 12:31:12 UTC
can you explain in more detail what has changed? I tested with latest master and the formula looks identical except for some adjustment that are necessary.
Comment 3 ndd.filter 2011-07-01 04:20:36 UTC
Created attachment 48647 [details]
problem cut down xls
Comment 4 ndd.filter 2011-07-01 04:27:52 UTC
added "problem cut down xls" attachment

the problem appears when using lists
formula
=INDEX(Table1,2,3)*INDEX(Table2,3,4)
opens as
=#NAME?*INDEX(INDEX(Table1,2,3),3,4)
Comment 5 Markus Mohrhard 2011-07-01 05:38:09 UTC
I have already fixed this, this will be in 3.4.2

*** This bug has been marked as a duplicate of bug 38204 ***