Download it now!
Bug 38830 - Print current page
Summary: Print current page
Status: RESOLVED DUPLICATE of bug 34697
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: easyHack
Depends on:
Blocks:
 
Reported: 2011-06-30 08:58 UTC by Björn Michaelsen
Modified: 2015-12-18 10:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Michaelsen 2011-06-30 08:58:33 UTC
Print current page

Background: In previous versions of OOo, there used to be a possiblity to print current page easily, but it got lost with the rework of the print dialog. The previous printing dialog made sure to set the field "Pages" according the currently active page number when the dialog was opened. It seems there is a demand for this feature, so it might be good to get it back :-)

Code pointers: For Writer, should be possible to pass the current page number to the SwPrintUIOptions's constructor wherever it is being constructed, probably in SwDocShell. If that is correct, in SwDocShell you have GetWrtShell(), and can do the same as this.

Something similar will be necessary for the other apps too.

Specification pointers: OOo CWS printerpullpages specification for mockups, OOo 3.1 printing dialog screenshots. Please also see: Bug 34697

Skills: building, C++
Comment 1 Stefan Knorr (astron) 2011-07-15 06:45:42 UTC
Sorry to say, but this is a dupe. I'll add the keywords to the original bug.

*** This bug has been marked as a duplicate of bug 34697 ***
Comment 2 tatung 2011-07-17 17:05:59 UTC
Please check the patch at #34679
https://bugs.freedesktop.org/show_bug.cgi?id=34697
Comment 3 Björn Michaelsen 2011-08-02 03:41:33 UTC
removing whiteboard status
Comment 4 Rainer Bielefeld Retired 2012-04-10 02:54:47 UTC
EasyHack tags unification: tags only allowed in Whiteboard to make queries more easy and reliable
Comment 5 Robinson Tryon (qubit) 2015-12-18 10:02:25 UTC
Migrating Whiteboard tags to Keywords: (EasyHack)
[NinjaEdit]