Bug 38848 - FILEOPEN: VIEWING LibreOffice_external_logo.SVG view cruelly damaged
Summary: FILEOPEN: VIEWING LibreOffice_external_logo.SVG view cruelly damaged
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 44184 (view as bug list)
Depends on:
Blocks: SVG-Open
  Show dependency treegraph
 
Reported: 2011-06-30 10:54 UTC by Rainer Bielefeld Retired
Modified: 2018-06-20 17:03 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Test kit for original report (60.88 KB, application/zip)
2011-06-30 10:54 UTC, Rainer Bielefeld Retired
Details
LibreOffice external Logo.svg in Chrome (34.18 KB, image/png)
2018-06-18 09:35 UTC, Roman Kuznetsov
Details
LibreOffice_external_logo.svg in LO Draw 6.1 beta 2 (27.42 KB, image/png)
2018-06-18 09:35 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-06-30 10:54:53 UTC
Created attachment 48616 [details]
Test kit for original report

The result with "LibreOffice 3.4.1RC1 – WIN7  Home Premium  (64bit) English UI [OOO340m1 (Build:103)]" ist completely unusable, please see attachment comparing result with the result of OOo 3.1.1 with SVG import extension. In the test kit you also find a LibO logo from the Wiki.

Strange, inserted SVG looks much better in WRITER (also black/white, but text is visible).
Comment 1 André Schnabel 2011-08-02 12:08:22 UTC
confirmed using LibO3.4.2

we should be able to import our own artwork :)

@thorsten - is soemone currently working on svg?
Comment 2 Björn Michaelsen 2011-12-23 13:24:48 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 3 tester8 2011-12-30 13:15:10 UTC
LOdev 3.5.0beta2 
4ca392c-760cc4d-f39cf3d-1b2857e-60db978
Ubuntu 10.04.3 x86
Linux 2.6.32-37-generic Russian UI

If I drug & drop it to WRITER - all fine. To DRAW - all ok too.
If I drug & drop it to start window it opens in DRAW and renders unproperly.
Comment 4 Rainer Bielefeld Retired 2011-12-30 23:04:17 UTC
*** Bug 44184 has been marked as a duplicate of this bug. ***
Comment 5 Rainer Bielefeld Retired 2011-12-30 23:09:51 UTC
There has been some progress until 3.5.0, but the fileopen result is less than unusable.

@Thorsten:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 6 Thorsten Behrens (CIB) 2013-09-12 16:14:55 UTC
Apologies for not having gotten around fixing this bug yet; unfortunately in future I'll have even less time at my disposal for this, so I'm freeing up ownership for other volunteers to take over.
Comment 7 QA Administrators 2015-09-04 02:48:04 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2015-11-18 11:37:51 UTC
Still black fill for shapes on open.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: b216cc1b8096eb60c27f67e8c27b7cd756c75e38
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-12_00:06:20
Locale: fi-FI (fi_FI)
Comment 9 Xisco Faulí 2015-11-18 14:20:49 UTC
SVG file looks better after 179f693ee0682c1e900f9047dfe67969c09a52f3, however it's not completely correct yet.
Comment 10 Robinson Tryon (qubit) 2015-12-09 18:52:43 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2017-10-30 08:33:47 UTC Comment hidden (obsolete)
Comment 12 Roman Kuznetsov 2018-06-18 09:35:06 UTC
Created attachment 142844 [details]
LibreOffice external Logo.svg in Chrome
Comment 13 Roman Kuznetsov 2018-06-18 09:35:39 UTC
Created attachment 142845 [details]
LibreOffice_external_logo.svg in LO Draw 6.1 beta 2

looks fine
Comment 14 Roman Kuznetsov 2018-06-18 09:36:18 UTC
in LibreOffice Draw 6.1 beta 2 svg looks fine

Status -> WFM