Bug 38888 - Undo/redo functionality for visual editor
Summary: Undo/redo functionality for visual editor
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
(earliest affected)
Hardware: Other All
: medium normal
Assignee: Not Assigned
Keywords: difficultyInteresting, easyHack, skillCpp
Depends on:
Reported: 2011-07-01 07:56 UTC by Björn Michaelsen
Modified: 2017-02-14 08:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Björn Michaelsen 2011-07-01 07:56:13 UTC
An experimental visual formula editor for starmath is included in the master branch. However, to enable it you need to open Options from the Tools menu, then under General, tick the "Enable experimental (unstable) features" check box. This feature allows for visual formula editing, as known from MathType, it not completely done yet (but you're welcome to help). Here is some of the easy and quite visible tasks, if you run into problems, have questions, what more tasks, by all means feel free to contact Jonas (jopsen on IRC or jopsen@gmail.com).

Background: Whenever the visual formula editor is used to change the formula, the command text is regenerated and updated in the SmEditWindow through the SmDocShell. This is done by calling EditEngine::SetText in SmCursor::EndEdit, however, using this method overrides undo/redo history, so it is not possible to undo/redo changes to the formula during visual editing. There must be a way to chagne the text in the EditEngine without overwritting undo/redo history. You'll most likely need to take a look at VCL to solve this issue, but it might be possible to find other code that modifies the an EditEngine.

Skills: Building, C++ taken by: luked - 68b84567@gmail.com - 2011-02-13
Comment 1 Florian Reisinger 2012-05-18 09:03:09 UTC
Deteted "Easyhack" from summary
Comment 2 Björn Michaelsen 2013-10-04 18:47:18 UTC
adding LibreOffice developer list as CC to unresolved EasyHacks for better visibility.

see e.g. http://nabble.documentfoundation.org/minutes-of-ESC-call-td4076214.html for details
Comment 3 Regis Perdreau 2015-09-07 13:55:01 UTC
This bug is reported as an Easyhack for developper. But it seems to be solved. Is it still open ? and what to do  ?
Comment 4 Robinson Tryon (qubit) 2015-12-14 05:03:41 UTC Comment hidden (obsolete)
Comment 5 Robinson Tryon (qubit) 2016-02-18 14:51:43 UTC Comment hidden (obsolete)
Comment 6 jani 2016-05-05 13:42:20 UTC
Seems solved, if not code pointers are missing, which are mandatory for easy hacks