Bug Hunting Session
Bug 38933 - python add-in cannot return array in calc in-cell function
Summary: python add-in cannot return array in calc in-cell function
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Extension-Manager
  Show dependency treegraph
 
Reported: 2011-07-03 11:40 UTC by kurt forrester
Modified: 2018-10-18 19:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
the project that fails to return an array in the spreadsheet (6.29 KB, application/zip)
2011-07-03 11:40 UTC, kurt forrester
Details
No numpy (52.81 KB, image/jpeg)
2011-07-03 13:52 UTC, noname
Details
a version of the addin without numpy (3.02 KB, application/vnd.openofficeorg.extension)
2011-07-03 13:56 UTC, kurt forrester
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kurt forrester 2011-07-03 11:40:28 UTC
Created attachment 48712 [details]
the project that fails to return an array in the spreadsheet

the project that fails to return an array in the spreadsheet

I have been developing LO add-in for Calc using python. I can successfully
create a in-cell function returning a single value, however, when I try and
convert it to an array function I continually get a value error
(http://www.oooforum.org/forum/viewtopic.phtml?t=124615&start=0&postdays=0&postorder=asc&highlight=).

I fear there is a bug within the python machinery preventing the correct
returning of the array to the spreadsheet cells. I have attached the package of
the project as I use it. I do hope someone can diagnose and potentially fix
this bug.
Comment 1 noname 2011-07-03 13:51:08 UTC
I can't even install your extension. That's because -by default- numpy isn't installed, at least not under windows [Win2K LibreOffice 3.4.1 OOO340m1 (Build:103)].
Comment 2 noname 2011-07-03 13:52:00 UTC
Created attachment 48713 [details]
No numpy
Comment 3 kurt forrester 2011-07-03 13:56:06 UTC
Created attachment 48714 [details]
a version of the addin without numpy

this is a version of the add-in removing the numpy requirement.
Comment 4 Björn Michaelsen 2011-12-23 12:25:25 UTC Comment hidden (obsolete)
Comment 5 kurt forrester 2011-12-30 14:58:48 UTC
This bug is still present. Tested on Windows 7 and still receive the same error.
Comment 6 QA Administrators 2014-06-25 17:38:03 UTC Comment hidden (obsolete)
Comment 7 Julien Nabet 2014-12-05 18:15:02 UTC
Kurt: any update with last stable LO version 4.3.4 (which uses Python 3.3)
Comment 8 kurt forrester 2014-12-06 09:43:10 UTC
the problem still exists (Windows 8.1 Libreoffice 4.3.4.1)
Comment 9 Julien Nabet 2014-12-06 11:35:56 UTC
Thank you Kurt for your feedback, I put it back to NEW.
Comment 10 QA Administrators 2015-12-20 16:21:37 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2017-01-03 19:51:17 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.1.6 or 5.2.3  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20170103