Bug 38957 - Flipping to UPPER CASE crashes the Writer
Summary: Flipping to UPPER CASE crashes the Writer
Status: RESOLVED DUPLICATE of bug 37044
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-04 13:32 UTC by Michael Inggs
Modified: 2012-04-10 00:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Crash report bug 38957 (64.24 KB, application/rtf)
2011-07-05 08:29 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Inggs 2011-07-04 13:32:47 UTC
If I highlight some text and under FORMAT select CHANGE CASE to UPPER CASE, the Writer crashes immediately, but does offer a restart and recovery.
Comment 1 Rainer Bielefeld Retired 2011-07-04 22:07:57 UTC
NOT reproducible with "LibreOffice 3.4.1RC1 - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:103)]"
Comment 2 Jeffrey 2011-07-05 02:10:04 UTC
Not reproducible with LibreOffice 3.4  340m1(Build:12) on OpenSuse for Linux either.
Comment 3 Jorendc 2011-07-05 08:29:00 UTC
Reproducible under Mac OS X 10.6.8; LibreOffice 3.4.1; Dutch language pack;
Crash report added;
Comment 4 Jorendc 2011-07-05 08:29:37 UTC
Created attachment 48776 [details]
Crash report bug 38957
Comment 5 Michael Inggs 2011-07-05 09:28:43 UTC
Does not happen with OS X 10.6.7 with the Writer packaged with LibreOffice 3.4.1 OOO340m1 (Build:103).
Checked that all case transformations worked under the CHANGE CASE tab.

No language packs installed.
Comment 6 Jorendc 2011-07-05 10:31:37 UTC
Mmh, strange. Just tried again after reading Comment 5 of Michael Inggs. No crash anymore...
Comment 7 Michael Inggs 2011-07-06 00:31:29 UTC
(In reply to comment #5)
> Does not happen with OS X 10.6.7 with the Writer packaged with LibreOffice
> 3.4.1 OOO340m1 (Build:103).
> Checked that all case transformations worked under the CHANGE CASE tab.
> 
> No language packs installed.

Went back to the 3.4.2 installation on my Macbook (also 10.6.7) and Writer still crashes when using the case change tool. If it is useful, I could upload the OS X debug report for the crash.
Comment 8 Björn Michaelsen 2011-12-23 12:28:02 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 9 Michael Inggs 2011-12-23 13:00:08 UTC
Downloaded the Beta 1

LOdev 3.5.0 
Build ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4

Can flip case upper to lower, and all the other variations without problems.

This version seems to have solved the problem for a OS X v 10.6.8

Regards
Comment 10 sasha.libreoffice 2012-02-16 04:52:23 UTC
due to last comment, change status to WorksForMe
Please, change status to Reopened if problem appears again
Comment 11 Florian Reisinger 2012-04-10 00:35:23 UTC
Ok, there are still problems, so I marked this bug as a duplicate...

*** This bug has been marked as a duplicate of bug 37044 ***