Bug Hunting Session
Bug 38962 - Truncated printing in landscape
Summary: Truncated printing in landscape
Status: RESOLVED DUPLICATE of bug 44664
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-04 17:23 UTC by shefla
Modified: 2013-01-11 22:55 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots (197.25 KB, application/bzip2)
2011-07-04 17:23 UTC, shefla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description shefla 2011-07-04 17:23:23 UTC
Created attachment 48750 [details]
Screenshots

Hi,

I am currently using LibreOffice 3.4  340m1(Build:103) in Archlinux 64 (Linux h 2.6.39-ARCH #1 SMP PREEMPT Mon Jun 27 21:26:22 CEST 2011 x86_64 Intel(R) Core(TM)2 Duo CPU E7600 @ 3.06GHz GenuineIntel GNU/Linux).

My printer is a HP LaserJet P1005.

I create a document in landscape format in the Writer application. When I print it, it is truncated. It is like if the landscape document is printed on a portrait page so left and right parts are truncated. You can see the result in the current.jpg attached picture.

It is the same with others LibreOffice applications like Draw.

When I create a PDF from the landscape Writer document with cups-pdf, the format is fine. When I print the PDF the result is fine as you can see in the target.jpg picture.

Other applications in Linux (text editor, web browser, ...) are printing properly.

This problem occurs with below versions:
libreoffice-3.4.1-1-x86_64.pkg.tar.xz
libreoffice-3.4.0-2-x86_64.pkg.tar.xz
libreoffice-3.4.0-1-x86_64.pkg.tar.xz

The problem has been fixed once I have downgraded libreoffice to libreoffice-3.3.2-2-x86_64.pkg.tar.xz.

Could you please fix this problem in version 3.4 ?

Thanks and regards
Comment 1 A M 2011-07-10 08:20:44 UTC
I confirm the bug. I've got it with Calc and samsung ML-1640.
Comment 2 jim 2011-07-19 19:36:15 UTC
I have the same thing in Writer with a Brother HL5340D.

(In reply to comment #1)
> I confirm the bug. I've got it with Calc and samsung ML-1640.
Comment 3 freedesktop 2011-11-08 22:08:11 UTC
I'm seeing the same thing (Gentoo linux with a Brother MFC-6490CW and app-office/libreoffice-3.4.3.2-r1).  However, from the websites listed below, I found a work-around: Goto File -> Printer Settings -> Properties -> Device and change "Printer Language Type" from PDF to one of the Postscript options.

I can also confirm the problem isn't present in 3.3.4; this is unsurprising since the "Printer Language Type" option is just "Postscript Level" (no PDF option) and I guess the problem is in the PDF part of the code.  

Websites:
<http://alien.slackbook.org/blog/libreoffice-3-4-3/>
<http://unix.stackexchange.com/questions/15938/libre-office-change-printer-language-type-from-pdf-to-postscript>
Comment 4 Caolán McNamara 2011-12-19 06:03:22 UTC
Can you try the standalone example in

https://bugzilla.redhat.com/show_bug.cgi?id=740496#c10
and 
https://bugzilla.redhat.com/show_bug.cgi?id=740496#c11

and see if that reproduces the problem as well
Comment 5 Trevor Cordes 2011-12-20 11:54:39 UTC
"Me too".  Brother HL-660 on Fedora 16 printing landscape in LO
Comment 6 Björn Michaelsen 2011-12-23 12:23:16 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 7 lanasth 2011-12-29 11:02:32 UTC
(In reply to comment #6)
> [This is an automated message.]
> This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
> started right out as NEW without ever being explicitly confirmed. The bug is
> changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
> to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2
> prereleases.
> Details on how to test the 3.5.0 beta1 can be found at:
> http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1
> 
> more detail on this bulk operation:
> http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

I tried something similar to this with 3.5 beta 2, and attached my bug report in related links.
Comment 8 freedesktop 2011-12-29 12:25:20 UTC
Not sure if Comment #4 is still relevant, but I tried printing the document (with lp -o PageSize=Letter landscape.pdf since I have letter-sized paper) and it showed up as indicated in the other bug (in portrait mode with the "ZZZZ" part of the text truncated off my printout).  I'm using a gentoo system with cups-1.4.8-r1 and ghostscript-gpl-9.04-r4.
Comment 9 Clemmitt Sigler 2012-01-11 06:42:28 UTC
Hi all,

(In reply to comment #3)
> I'm seeing the same thing (Gentoo linux with a Brother MFC-6490CW and
> app-office/libreoffice-3.4.3.2-r1).

Apologies, but this is yet another "me, too!" from a Brother printer user.  

In Comment 3, freedesktop seems to me to have, at least in part, isolated the problem to the Printer Language Type option.  I see the same effect.  It also seems to affect mainly Brother printers???  (I run Gentoo as well, but don't have the native port of LibreOffice installed.  I always download the prebuilt version via bittorrent.  Moreover, I don't think this is specific or related to Gentoo.)

HTH.

Clemmitt
Comment 10 Julian G 2012-01-12 07:21:14 UTC
I've got the same problem with two HP Printers (OfficeJet K5400 Pro and another one) and Brother MFC 8880DN. Using Fedora 16 i386 and x86-64.
Comment 11 sasha.libreoffice 2012-01-27 09:04:35 UTC
see comments from this bug for workaround:
Bug 44664 - Calc PRINTING: printer prints Landscape page orientation as Portrait
Comment 12 Caolán McNamara 2012-02-27 02:15:28 UTC
#8 suggests it can be replicated on the command line i.e. "I tried printing the document (with lp -o PageSize=Letter landscape.pdf) and it showed up as indicated in the other bug (in portrait mode with the "ZZZZ" part of the text truncated off my printout)." so I reckon this is probably a problem in cups

*** This bug has been marked as a duplicate of bug 44664 ***
Comment 13 Przemyslaw Kaplon 2013-01-11 22:23:01 UTC
I had the same perobelem after upgrading from Ununtu 12.04 to Xubuntu 12.10 with Brother USB Printer DCP 7030. 
I solved the problem very easy:
In the printer properties under "connection" I had:
usb://Brother/DCP-7030? Serial...[number]
I just edited this value and left only:
"usb://Brother/DCP-7030"
And... the problem diappeared.

Best Regards

Przemek
Comment 14 Przemyslaw Kaplon 2013-01-11 22:55:55 UTC
Sorry, it wasa miastake. The problem unfortunatwely still exists