Bug Hunting Session
Bug 38963 - Format Cells -- Currency Checkboxes Cause Calc to Crash
Summary: Format Cells -- Currency Checkboxes Cause Calc to Crash
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: target:3.5 target:3.4.2
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-04 19:43 UTC by Jeffrey
Modified: 2011-12-23 14:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace of the crash for (Mark in Red) in LO 3.4 (24.63 KB, text/x-log)
2011-07-04 22:48 UTC, Jeffrey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeffrey 2011-07-04 19:43:56 UTC
Found in OpenSuse while looking at Bug 38956.

How to reproduce:

1. Format -> Cells
2. Select Currency under category
3. Select -$1234.-- (in Red)
4. Un-check thousands separator or Mark as Red and Calc crashes

Error message produced in terminal:

KCrash: Application 'soffice.bin' crashing...
Warning: connect() failed: : No such file or directory
KCrash cannot reach kdeinit, launching directly.
Comment 1 Rainer Bielefeld Retired 2011-07-04 22:33:48 UTC
[Reproducible] with "LibreOffice 3.4.1RC1 - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:103)]". For me it's not 100% reporducible, but gambling a while with those 2 checkboxes will cause a crash from time to time.

Might be related to "Negative Red" checkbox malfuncition, I can't unselect "Negative Red" reliable, but until now I was unable to find out a way to mke that 100% reproducible - because of the crashes.

@Kohei:
Can you please check?
Comment 2 Jeffrey 2011-07-04 22:48:58 UTC
Created attachment 48754 [details]
Backtrace of the crash for (Mark in Red) in LO 3.4

Program received signal SIGSEGV, Segmentation fault.
0xb7559d39 in SvNumberformat::IsNegativeInBracket() const () from /opt/libreoffice3.4/program/../basis-link/program/libsvlli.so.
Comment 3 Markus Mohrhard 2011-07-05 08:30:01 UTC
I'll have a look at it. Thank you very much for your backtrace.
Comment 4 Markus Mohrhard 2011-07-06 20:16:08 UTC
my first idea after some debugging is that it will happen every time it can't find a corresponding build-in format

So I think it will only happen if changing the options results in a switch from build-in to user defined and then the check for brackets cause a crash
Comment 5 Markus Mohrhard 2011-07-07 03:13:02 UTC
hopefully I got it, pushed a patch to master