Download it now!
Bug 39032 - [Calc] Specific xls file crashes on open (non-contiguous data range in chart)
Summary: [Calc] Specific xls file crashes on open (non-contiguous data range in chart)
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-07 05:12 UTC by Stephan Zietsman
Modified: 2012-11-22 08:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
xls file with 4 data points and chart (non-contiguous data range) (8.00 KB, application/msexcel)
2011-07-07 05:12 UTC, Stephan Zietsman
Details
What I see on my screen when opening first attachment. (196.51 KB, image/png)
2011-07-07 08:00 UTC, Jeffrey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Zietsman 2011-07-07 05:12:29 UTC
Created attachment 48849 [details]
xls file with 4 data points and chart (non-contiguous data range)

The attached xls file causes LibO to crash in Windows 7.  It opens on MS Office Excel 2007 without a problem.

--==  To reproduce  ==--
Start LibreOffice
Open Non-contiguous.xls (File -> Open -> Non-contiguous.xls -> Open)

Expected: File opens (contains 4 data points and a chart)
Result: LibO crashes (LibreOffice Document Recovery window opens, with no files in the pane)

--==  End of reproduction  ==--

I've started a thread on the users@global.libreoffice.org list asking whether the file crashes other systems (http://listarchives.libreoffice.org/global/users/msg07745.html).  Unfortunately, I can find no consistency from the responses: the same version and OS works for one user, but not for another.  No user reported a crash in 3.4.x, it looks localised to the 3.3.x branch, but I couldn't say for sure.  Even my portable version crashes on Win7 but not WinXP.  Also tested OOo 3.2.0 portable on WinXP: did not crash.

The file itself was created as a test case for another bug (https://bugs.freedesktop.org/show_bug.cgi?id=38746), which also seems to affect some users and not others. 

If I remember correctly, I did create this file in LibO, but it is possible that it was created in MS Office 2007 (though I doubt it).

I'm selecting the "Severity" as "Major" since it causes LibO to crash (possible data-loss).

-- 
Running LibreOfficePortable 3.3.2 (as from portableapps.com)
On Windows 7 Professional x64
About:
LibreOffice 3.3.2 
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2
Comment 1 Cor Nouws 2011-07-07 05:28:32 UTC
crashes when I try to open in 3.3.3 or 3.3.2 on Ubuntu
Does not crash when I open it in 3.4.1
Comment 2 Sigrid Carrera 2011-07-07 07:22:41 UTC
Hi, 

I'm making my comments anew, since they changed. 

I am running Linux (Mageia 1, 32 bit, rpm-based Distro): 

- Version 3.3.2 (Distro-version) does not crash.

- Version 3.3.3 (Vanilla version) does not crash.

- Version 3.4.1 (Vanilla version) does not crash.

What did I change? 

I uninstalled the previous (vanilla) version of 3.3.3 and reinstalled it, using a different install path and its own user directory. (Before it shared the user directory with the distri-version). 

Sigrid
Comment 3 Jeffrey 2011-07-07 08:00:39 UTC
Created attachment 48853 [details]
What I see on my screen when opening first attachment.

Experimented with this situation on LibreOffice 3.4  340m1(Build:12) for OpenSuse Linux.

Downloaded the attachment, saved it. Opened it via Shell. No crash, but the graph does not appear properly. (Black white box with blank gray. Check attachment.) I can successfully type extra numbers in the cells.

I thought this might just be helpful seeing that survey might be the best option here.
Comment 4 Planas 2011-07-07 14:47:37 UTC
Jay Lozier

Tested on Ubuntu/Pinguy 11.04 LO 3.4.1 - no problems, clean install of LO.
Comment 5 Björn Michaelsen 2011-12-23 12:21:47 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 6 Florian Reisinger 2012-08-14 13:58:15 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 13:59:32 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 8 Florian Reisinger 2012-08-14 14:04:08 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 9 Florian Reisinger 2012-08-14 14:06:21 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 10 sasha.libreoffice 2012-09-26 14:17:07 UTC
reproduced in 3.3.4, not reproduced in 3.5.5 and 3.6.1 on Fedora 64 bit
IMHO status should be WFM
Comment 11 Stephan Zietsman 2012-11-01 16:14:00 UTC
Just tested the original attachment attachment.  Opens fine, no crash.  The data also appears correctly (both in the cells and the graph).

This bug does indeed seem to be resolved.

-- 
Running LibreOffice 3.6.2.2 (as from Ubuntu 12.10 repository)
On Ubuntu 12.10
About:
Version 3.6.2.2 (Build ID: 360m1(Build:2))