Bug 39041 - WRITER PDF Export with bookmarks crashes
Summary: WRITER PDF Export with bookmarks crashes
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: (target:3.5.0)
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-07 08:53 UTC by Pit
Modified: 2013-04-06 07:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
file making the export crash cleaned up as much as possible (27.92 KB, application/vnd.oasis.opendocument.text)
2011-07-07 08:53 UTC, Pit
Details
Backtrace log for PDF crash. (29.57 KB, text/x-log)
2011-07-07 19:23 UTC, Jeffrey
Details
new odt file (to reformat) for test (21.39 KB, application/vnd.oasis.opendocument.text)
2012-03-24 10:15 UTC, Julien Nabet
Details
About the crash quoted in my last comment (117.46 KB, text/x-log)
2012-03-24 10:17 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pit 2011-07-07 08:53:01 UTC
Created attachment 48859 [details]
file making the export crash cleaned up as much as possible

In our production environment we're using LibreOffice to convert odt files to pdf files. 
The attached file made the PDF export crash : 
libreoffice-server shuts down (soffice -accept...).

To reproduce the bug manually : open the attached file, don't scroll don't click, just go directly to the "Export as PDF option".
Comment 1 Jeffrey 2011-07-07 19:23:07 UTC
Created attachment 48873 [details]
Backtrace log for PDF crash.

Reproduced on LibreOffice 3.4  340m1(Build:12) for OpenSuse Linux.

I have also attached the backtrace log for the crash. Hopefully it is helpful for someone who may be working on this.
Comment 2 Rainer Bielefeld Retired 2011-07-07 21:58:05 UTC
[Reproducible] with "LibreOffice 3.4.1RC1 - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:103)]".

For me the reproducible condition for the crash is that preference "Export Boomarks" is selected.

Also crashes without picture (deleted)
No more crash after I additionally deleated first table row (containing "Une saine gestion".

Not a general problem, I create several such PDFs with WRITER every day.

LibO 3.3.0 based Portable version also crashes

OOo 3.4.1-dev (obsolete version) and 3.1.1 WIN do not crash

@Pit:
Thank your for your attention!

@Cédric:
Any Idea?
Please feel free to reassign if it’s not your area or if provided information is not sufficient.
Comment 3 Pit 2011-07-08 00:45:08 UTC
(In reply to comment #2)
Thanks for your attention guys ! 

I forgot to mention that to reproduce our workflow I only edited the file with OOo 3.3.0 (on ubuntu 10.10 x64) as the person who generated the bug uses OOo. 

And when I delete the picture with OOo (then save and try to reproduce as descripted in the first place) I don't reproduce the bug. 

Hope this helps. 
Thanks again! 
Pit
Comment 4 Julien Nabet 2012-03-24 10:15:24 UTC
Created attachment 58978 [details]
new odt file (to reformat) for test

On pc Debian x86-64 with 3.5 branch updated today, I didn't reproduce the crash.

However, I hadn't the picture on the pdf so I tried to copy paste the table on a brand new file but had a crash. So I copied the content of the table (not the table), no crash and all was exported on the pdf. Now you just have to reformat.

I wonder if the crash is not linked with this :
http://nabble.documentfoundation.org/Bug-45522-Crash-when-copying-table-between-Writer-and-other-LibreOffice-programs-td3810131.html

I'll add a new attach after this one
Comment 5 Julien Nabet 2012-03-24 10:17:13 UTC
Created attachment 58979 [details]
About the crash quoted in my last comment

# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f3826c04050, pid=12455, tid=139879621818528
#
# JRE version: 6.0_24-b24
# Java VM: OpenJDK 64-Bit Server VM (20.0-b12 mixed mode linux-amd64 compressed oops)
# Derivative: IcedTea6 1.11.1
# Distribution: Debian GNU/Linux unstable (sid), package 6b24-1.11.1-3
# Problematic frame:
# C  [libswlo.so+0x72c050]  SwRootFrm::GetCurrShell() const+0xc
Comment 6 Julien Nabet 2012-05-05 10:03:37 UTC
Any update about this bug with last LO version (3.5.3) ?
Comment 7 Rainer Bielefeld Retired 2013-04-06 07:24:17 UTC
No longer reproducible with  "LibreOffice 3.6.6.2 rc " German UI/ German Locale [Build-ID: f969faf] {pull date 2013-04-03} on German WIN7 Home Premium (64bit) 

No news so WFM, target info due to Comment 4

@Julien / reporter:
Please feel free to reopen this bug if you find out that the problem still exists with the current stable LibreOffice version.