Bug 39045 - Functions VAR, VARP, STDEVP return an incorrect value when applied to a range.
Summary: Functions VAR, VARP, STDEVP return an incorrect value when applied to a range.
Status: RESOLVED DUPLICATE of bug 46119
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-07 11:19 UTC by blargh
Modified: 2012-02-15 09:15 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
File with a macro which emplyes the mentioned functions (11.37 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-07-07 11:19 UTC, blargh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description blargh 2011-07-07 11:19:39 UTC
Created attachment 48862 [details]
File with a macro which emplyes the mentioned functions

Functions:
  com.sun.star.sheet.GeneralFunction.VAR
  com.sun.star.sheet.GeneralFunction.VARP
  com.sun.star.sheet.GeneralFunction.STDEVP
return 1,32714623487911E-315 (~zero...) when applied to a range.

(but functions com.sun.star.sheet.GeneralFunction.MAX, MIN, AVERAGE and SUM are working properly)

It has also been reported here: http://openoffice.org/bugzilla/show_bug.cgi?id=101713
Comment 1 Björn Michaelsen 2011-12-23 12:21:14 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 blargh 2012-02-15 09:15:18 UTC

*** This bug has been marked as a duplicate of bug 46119 ***