Bug Hunting Session
Bug 39106 - Icons separators in toolbar vertically docked should be horizontal
Summary: Icons separators in toolbar vertically docked should be horizontal
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: All Linux (All)
: medium normal
Assignee: Ivan Timofeev (retired)
URL:
Whiteboard: target:3.6.0 target:3.5.4
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-07-09 22:39 UTC by Jean-Baptiste Faure
Modified: 2012-05-09 03:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Tools toolbar with all default icons (5.70 KB, image/png)
2011-07-11 02:34 UTC, Jean-Baptiste Faure
Details
Tools toolbar with only the first icon checked (2.23 KB, image/png)
2011-07-11 02:35 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2011-07-09 22:39:50 UTC
If you dock a toolbar on the left or right of the window, then the icons separators become small vertical line on the left side of the toolbar.
That is not aesthetic and seems to have strange effects when you try to hide all but one button in your toolbar.

Of course same problem in the master.

Best regards. JBF
Comment 1 Jeffrey 2011-07-10 18:38:28 UTC
I am having a difficult time reproducing this on LibreOffice 3.4  340m1(Build:12) Writer for OpenSuse KDE.

What I have done is dock several kinds of toolbars, some on the left and some on the right. Only the Bullets and Numbering toolbar seems to be causing problems.

Here are some of the things I have done:

I go to view->toolbars, chose Bullets and Numbering, docked it vertically on the right of writer. Even without hiding all but one of the buttons, when I use "Bullets On/Off", the toolbar seems to disappear after called.

I have also tried docking toolbars such as drawing and insert on left and right, and hiding all but one does not seem to cause any strange effects after triggering the one button.

JBF, can you specify which toolbars you have tried and on what OS? Perhaps I am missing something.
Comment 2 Jean-Baptiste Faure 2011-07-11 02:34:32 UTC
Created attachment 48958 [details]
Tools toolbar with all default icons
Comment 3 Jean-Baptiste Faure 2011-07-11 02:35:52 UTC
Created attachment 48959 [details]
Tools toolbar with only the first icon checked
Comment 4 Jean-Baptiste Faure 2011-07-11 02:36:18 UTC
My system is Ubuntu 10.04 x86_64
Here are 2 screenshots for the toolbar Tools. 
For Capture_toolbar1.png I keep all default icons and you can see the separators as small vertical lines.
For Capture_toolbar2.png I have hidden all icons and separators but the first icon. You can see that the first separator is still there. If you reopen the modification dialog you will see that all separators are checked back.

Best regards. JBF
Comment 5 Ivan Timofeev (retired) 2012-05-05 11:34:13 UTC
Should be fixed with 
http://cgit.freedesktop.org/libreoffice/core/commit/?id=f1005e50e795a06b5504960a94e529b48e085a91

P.S. I should search for bug reports before fixing something... :)
Comment 6 Jean-Baptiste Faure 2012-05-06 10:01:22 UTC
(In reply to comment #5)
> Should be fixed with 
> http://cgit.freedesktop.org/libreoffice/core/commit/?id=f1005e50e795a06b5504960a94e529b48e085a91

Yes it is in current master (Build ID: 32af02b) ! Many thanks !
> 
> P.S. I should search for bug reports before fixing something... :)
:-) :-) :-)
Comment 7 Jean-Baptiste Faure 2012-05-09 01:19:45 UTC
Hi Ivan,

is this fix eligible for backport to 3.5 ?

Best regards. JBF
Comment 8 Ivan Timofeev (retired) 2012-05-09 01:52:01 UTC
(In reply to comment #7)
> is this fix eligible for backport to 3.5 ?

Proposed a more simple fix now.
Comment 9 Not Assigned 2012-05-09 03:08:29 UTC
Ivan Timofeev committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f17ceb9b6d6dc16a2b276a6e81aa674d87d137e1&g=libreoffice-3-5

fdo#39106: properly draw separators in vertical toolbars


It will be available in LibreOffice 3.5.4.
Comment 10 Jean-Baptiste Faure 2012-05-09 03:49:45 UTC
Great! Works as expected in LO 3.5.4rc0+ (Version ID : f17ceb9-a73d29c-6845e52-f269e46-b9d7d05)

Thank you Ivan. 
JBF