Bug Hunting Session
Bug 39117 - Borders made with macros dont work as expected - FORMATTING
Summary: Borders made with macros dont work as expected - FORMATTING
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Eike Rathke
URL:
Whiteboard: target:3.4.6 target:3.5.0.3 target:3....
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-07-10 09:36 UTC by ansuransax
Modified: 2012-02-03 13:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Document with a macro to draw the borders and a screenshot (37.27 KB, application/zip)
2011-07-10 09:36 UTC, ansuransax
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ansuransax 2011-07-10 09:36:08 UTC
Created attachment 48937 [details]
Document with a macro to draw the borders and a screenshot

When I try to make borders of a cell range only the Right and Bottom border appears. It should draw borders on Left, Top, Right and bottom. So Left and Top are missing.
Checking this with Format -> Cells... -> Borders confirms that only the Right and Bottom borders are drawn.
This issue appears on Linux and Windows (both 64-Bit)
This issue is not present in Libreoffice 3.3

I attached a screenshot and a file to test this.
Comment 1 ansuransax 2011-07-10 09:39:31 UTC
Sorry, i should have mentioned it, this only happends if to draw the borders you use a macro
Comment 2 Rainer Bielefeld Retired 2011-07-11 00:49:05 UTC
[Reproducible] with "LibreOffice 3.4.1  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:103)]", also with a Build:101 related Daily build from July-08.
I even only get a horizontal border between 'B3:C3' and 'B4C4'

Works fine with an old Libo Portable version, OOo 3.1.1 and OOO-dev 3.4 (obsolete).

@Noel
Please feel free to reassign if it’s not your area!
Comment 3 Noel Power 2011-07-15 08:54:39 UTC
back to list, afaict this is not macro related interestingly this seems to be fixed in master
Comment 4 Rainer Bielefeld Retired 2011-07-15 10:17:53 UTC
I still see the problem with Master "LibO-dev 3.4.5  – WIN7  Home Premium  (64bit) English UI 
[(Build ID:d337f79-a24c961-2865670-9752b71-7f8fd43
	2fdd60d-fd28b6a-fd7bf20-aa369cb-28da3fb
	6a9633a-931d089-ecd263f-c9b55e9-b31b807
	82ff335-599f7e9-bc6a545-1926fdf)]"
Comment 5 Björn Michaelsen 2011-12-23 13:24:50 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 6 Michael Stahl (CIB) 2012-02-03 13:44:28 UTC
regression in 3.4

fixed on master by:
97c66b3b13528cc50f271217663718b3d6681bd9

fixed on libreoffice-3-5:
b1718b9dd74e13cd0f7aeccdb1187729c68687f3

fixed on libreoffice-3-4:
http://cgit.freedesktop.org/libreoffice/calc/commit/?h=libreoffice-3-4&id=ff3a6a514d4a95653d111610ea06954b8130a869