Download it now!
Bug 39187 - Mouse pointer disappears instead of changing to "move arrows"
Summary: Mouse pointer disappears instead of changing to "move arrows"
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-07-13 06:01 UTC by Rainer Bielefeld Retired
Modified: 2011-12-23 13:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-07-13 06:01:01 UTC
With "LibO-dev 3.4.5  – WIN7  Home Premium  (64bit) English UI 
[(Build ID:d337f79-a24c961-2865670-9752b71-7f8fd43
	2fdd60d-fd28b6a-fd7bf20-aa369cb-28da3fb
	6a9633a-931d089-ecd263f-c9b55e9-b31b807
	82ff335-599f7e9-bc6a545-1926fdf)]"

I found a problem, steps to reproduce
0. Open a WRITER document
1. Move mouse pointer to left grip of any docked task bar
   Expected
   Actual: Reaching the grip (where mouse button should be pushed 
           for drag and drop) the arrow mouse pointer disappears
3. Push left button and drag / drop toolbar
   it works without problem, so it's only a mouse pointer visibility problem

You will see the same problem when you select a drawing element. You will not see the 4-Arrows-move-mousepointer

    ˄
    |
  ˂---˃
    |
    ˅

Other move-mousepointers (for example to move a control point) work fine
Comment 1 Rainer Bielefeld Retired 2011-07-13 06:33:50 UTC
It's the same with the link click mouse pointer.
Comment 2 Jacqueline Rahemipour 2011-08-02 12:36:37 UTC
Confirmed with LibO-dev 3.4.5 Win 7, the mouse pointer disappears, when it should only change its appearance.
Comment 3 Rainer Bielefeld Retired 2011-09-01 21:41:04 UTC
No longer a problem with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: a6adae1-4eb4f62-09af278)]"
Comment 4 Björn Michaelsen 2011-12-23 13:27:07 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.