Bug Hunting Session
Bug 39195 - FILEOPEN Excel file, formula with vlookup drops range parameter
Summary: FILEOPEN Excel file, formula with vlookup drops range parameter
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:3.5 target:3.4.2
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-13 07:55 UTC by Richard
Modified: 2013-11-24 21:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Excel file (13.50 KB, application/vnd.ms-excel)
2011-07-13 07:56 UTC, Richard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard 2011-07-13 07:55:19 UTC
When opening an Excel file that has formulae with vlookup the range parameter is dropped.

Original Formula:  =vlookup(A2,l_u_range,2,0)
    (lookup value in cell A2 in the range called l_u_range and return the value
     from column 2, no softseek).

Converted Formula in LO 3.41:  =vlookup(A2,2,0)

Attached file demonstrates (created with Excel 2000)
Comment 1 Richard 2011-07-13 07:56:42 UTC
Created attachment 49043 [details]
Test Excel file
Comment 2 Jeffrey 2011-07-14 20:57:51 UTC
Reproduced on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux.
Comment 3 Markus Mohrhard 2011-07-19 11:44:47 UTC
should be fixed in 3.4.2 or 3.4.3

I have for example =VLOOKUP(A2,test,2,0) with a fresh build from the 3-4 branch

can you confirm that this is expected and then test with 3.4.2RC2? It will be available at the end of the week

If all works fine please mark as resolved - fixed
Comment 4 Markus Mohrhard 2011-07-21 02:30:59 UTC
seems to be another duplicate of bug 38204

*** This bug has been marked as a duplicate of bug 38204 ***
Comment 5 Richard 2011-08-02 08:00:25 UTC
I have downloaded the 3.4.2 version (1 Aug 2011) and have seen that it was fixed.

Thank You very much.