Bug 39208 - Crash while pasting into spreadsheet
Summary: Crash while pasting into spreadsheet
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-13 13:07 UTC by Jamie M
Modified: 2012-03-01 21:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jamie M 2011-07-13 13:07:20 UTC
Running LibreOffice 3.4.1 OOO340m1 (Build: 103) on OSX 10.6.

Attempting to paste data from Chromium into a new, blank spreadsheet. The data in question is one table from http://www.bcferries.com/schedules/southern/vade-current.html - specifically Tsawwassen to Mayne Island with the copy selection going from just before the "Leave" heading to just after the final 9:30PM timestamp.

Upon pressing CMD+V to paste, I'm prompted to select a language to paste, and both cancelling that dialog or accepting the "automatic" option both result in a hard crash. After relaunching LibreOffice I am prompted to recover the (empty) document.
Comment 1 Rainer Bielefeld Retired 2011-07-13 23:20:00 UTC
NOT reproducible with copy / paste from "Seamonkey" browser and "LibO-dev 3.4.5  – WIN7  Home Premium  (64bit) English UI 
[(Build ID:d337f79-a24c961-2865670-9752b71-7f8fd43
	2fdd60d-fd28b6a-fd7bf20-aa369cb-28da3fb
	6a9633a-931d089-ecd263f-c9b55e9-b31b807
	82ff335-599f7e9-bc6a545-1926fdf)]"
I proceeded as per report and indeed I had several times "not responding", but after a minute I had the contents in the sheet. Long waiting seems to be caused by waiting for pictures. Copy / Paste to writer was much faster.

Mac or Browser related?
Comment 2 Björn Michaelsen 2011-12-23 12:24:16 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 sasha.libreoffice 2012-03-01 03:14:06 UTC
@ Jamie M
Thanks for bugreport
Please, verify: in last version of LibreOffice still reproducible?
Comment 4 Jamie M 2012-03-01 07:54:07 UTC
LibreOffice 3.5.0rc3
Chromium 19.0.1058.0 (Developer Build 124409 Mac OS X)

Following my reproduction notes no longer crashes.
Comment 5 sasha.libreoffice 2012-03-01 21:02:04 UTC
Thanks for additional testing
Due to last comment, changing status to WorksForMe

Please, if problem appears again, change status to Reopened