Bug Hunting Session
Bug 39229 - UI: Visible icons hidden in Table Toolbar
Summary: UI: Visible icons hidden in Table Toolbar
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: (target:4.2.4)
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-07-14 08:52 UTC by Rainer Bielefeld Retired
Modified: 2014-05-30 14:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot, pls. see original report! (112.81 KB, application/pdf)
2011-07-14 08:52 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-07-14 08:52:17 UTC
Created attachment 49091 [details]
Screenshot, pls. see original report!

I see with "LibO-dev 3.4.5  – WIN7  Home Premium  (64bit) English UI 
[(Build ID:d337f79-a24c961-2865670-9752b71-7f8fd43
	2fdd60d-fd28b6a-fd7bf20-aa369cb-28da3fb
	6a9633a-931d089-ecd263f-c9b55e9-b31b807
	82ff335-599f7e9-bc6a545-1926fdf)]", that several icons that should be visible due to 'Visible Buttons' are not visible. Resizing (pulling the bottom of the toolbar down) makes the hidden icons visible. 

I have been used to see that the autosize for toolbar works perfectly, but here we seem to have a little problem? Please see my attached screenshots

I did no search for similar problems in other toolbars.
Comment 1 Jacqueline Rahemipour 2011-08-02 12:26:34 UTC
Reproducible with LibO-dev 3.4.5, Win 7. This happens only with the table toolbar in Draw and Impress, in Writer all icons are visible. Did not find any other toolbars with this problem.
Comment 2 Rainer Bielefeld Retired 2011-09-11 22:38:49 UTC
Still a problem with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  d3d1481-3f8994a-2ba0a9f)]", REGRESSION
Comment 3 Björn Michaelsen 2011-12-23 13:24:39 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 4 Julien Nabet 2012-10-27 22:17:51 UTC
On pc Debian x86-64 with 3.5, 3.6 and master sources, the 3 updated today, I don't reproduce this problem. Perhaps missed something?
Rainer: would you have some time to give a try with a recent LO version?
Comment 5 Rob Snelders 2012-12-21 22:33:20 UTC
Can you please retry with 4.0-beta1 as the toolbar seems to be redesigned.
Comment 6 Yousuf Philips (jay) (retired) 2014-05-30 08:25:35 UTC
Tested on 4.2.4
Comment 7 Julien Nabet 2014-05-30 14:16:28 UTC
Thank you Jay for the test. I just the target (put in parentheses because there's no specific fix)