Bug 39262 - FILEOPEN: wrong footer display in specific .doc with weird footer structure
Summary: FILEOPEN: wrong footer display in specific .doc with weird footer structure
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability Confirmed:4.3.0.0.al...
Keywords: filter:doc
Depends on:
Blocks: DOC Writer-Styles-Page-Odd-Even
  Show dependency treegraph
 
Reported: 2011-07-15 07:55 UTC by Stephanie Miller
Modified: 2018-10-09 15:53 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example word doc (398.00 KB, application/msword)
2011-07-15 07:55 UTC, Stephanie Miller
Details
pdf produced in MSWord 2003 (118.72 KB, application/pdf)
2012-01-27 10:20 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephanie Miller 2011-07-15 07:55:20 UTC
Created attachment 49152 [details]
Example word doc

The attached word file has different even/odd footers as well as different first page footers.  They all come from a template that is used.  Somehow LibreOffice is choosing to use a different footer on odd numbered non first pages than word chooses.  

If you look at page 3 of the attached document in word the footer will have a date at the bottom right of "07 - 01 - 2011", if you view it in LibreOffice it will have a date of "09 - 01 - 2009".  This date is from some much older version of the file/the template maybe?  Either way the two should not choose different footers, this is incorrect.

The wrong footer is not visible anywhere in word, and the problem still shows if you convert the file to docx (using word 2010).  Converting to docx also really messes up the tables in LibreOffice, though obviously I need to file a different bug for that.
Comment 1 Jeffrey 2011-07-17 17:24:55 UTC
Reproduced on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux.

When you open the document on Word, it looks like pages 1, 2, and 4's footers are linked to each other, while page 3's is not. When you click the "Link to Previous" button under Design while you have selected the footer on page 3, the date will change to "09-01-2011", which probably explains why this occurs in LO Writer. Perhaps it is making the link by default, causing this buggy date. I am just curious as to why the date changes to a different one than the other three pages.

So even though Word and LO bug up, it looks like the problem is caused by a faulty connection between footers across the pages.
Comment 2 Björn Michaelsen 2011-12-23 12:25:42 UTC Comment hidden (obsolete)
Comment 3 sasha.libreoffice 2012-01-27 10:20:12 UTC
Created attachment 56232 [details]
pdf produced in MSWord 2003

reproduced in LibO 3.6.0 master on Fedora 64 bit
Comment 4 Jorendc 2013-02-18 09:47:10 UTC Comment hidden (obsolete)
Comment 5 Stephanie Miller 2013-02-18 21:53:50 UTC
I am still seeing this in 4.0.0.3 on Windows 7.

If you look at the footers on pages 1,2, and 4 they all read "07-01-2011" and on page 3 it reads "09-01-2009".  All 4 are supposed to read "07-01-2011".
Comment 6 retired 2013-12-08 12:05:30 UTC
Interesting bug. Can confirm that with LO Version: 4.3.0.0.alpha0+
Build ID: 5e01904de993caa3d497a8f6c82a846336e70eef
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-12-06_02:05:01

I still see 2009 in the footer on page 3 while in MS Word 2011 on OS X I see 2011.

Any dev willing to look into this?
Comment 7 QA Administrators 2015-04-19 03:19:53 UTC Comment hidden (obsolete)
Comment 8 Gordo 2015-04-21 18:54:04 UTC
Still reproducible.

Headers and footers are saved with the page style.  I noticed upon opening the document that the page style is set to Default Style.  If you change it to Convert1, then the date is changed to the correct one.  Saving, closing, and reopening the document changes the Convert1 style to Default Style.  It has now been assimilated.

Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Comment 9 tommy27 2015-10-10 06:26:29 UTC
wrong footer in page 3 bug still present under Win8.1x64 using LibO 5.1.0.0.alpha1+
Build ID: f830600ece806ec365a4839e79afabe183c5e36d
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-06_22:49:09
Locale: it-IT (it_IT)

bug is inherited from OOO and is reproducible in OOo 3.3.0 and AOO 4.1.0

I add writer expert to CC list.
@Michael Stahl
any idea how to fix this?
Comment 10 QA Administrators 2016-11-08 11:03:17 UTC Comment hidden (obsolete)
Comment 11 tommy27 2016-11-13 10:45:59 UTC
bug unchanged in LibO 5.2.3.3 and recent 5.3.0.0 daily build
Comment 12 Timur 2018-10-08 15:27:37 UTC
Repro with 6.2+, both if we save in MSO as DOC and DOCX.
But if we open that zip:

footer1 (diff. 1st page) has 07 - 01 - 2011

footer2 (even, diff. odd&even, same as/link to previous) has: 
		<w:t>09 - 01 - 2009</w:t>

footer3 (odd, diff. odd&even) has:
		<w:bookmarkStart w:id="0" w:name="OLE_LINK1"/>
		<w:r>
			<w:rPr>
				<w:b/>
				<w:sz w:val="16"/>
			</w:rPr>
			<w:t>07 - 01 - 201</w:t>
		</w:r>
		<w:bookmarkEnd w:id="0"/>
		<w:r>
			<w:rPr>
				<w:b/>
				<w:sz w:val="16"/>
			</w:rPr>
			<w:t>1</w:t>
		</w:r>


footer4 (even, diff. odd&even, same as/link to previous) has: 
		<w:t>07-01-2011</w:t>

While LO displays this differently from MSO so bug was valid, taking into account weird sample file footer content I guess it's safe enough to say this won't be fixed. 
If I'm wrong, there are 2 devs here hopefully to correct me.
Comment 13 Justin L 2018-10-09 15:53:29 UTC
(In reply to Timur from comment #12)
> If I'm wrong, there are 2 devs here hopefully to correct me.
You are not wrong. Just before the table there is a continuous section break. That means that the footers used in Word from that point on will be defined in section 2 (footer 4). However, LibreOffice has no good way of knowing where the page break will be, so it can't know when to switch to the next section. LO simply doesn't have any similar concept to "dynamic assignment of headers/footers at a natural page break".
Plus, there are a million other bug reports on the same topic, so this would otherwise be a duplicate of bug 81426.